Bug 36540 - HTML Tables Don't Know Size of MathML Content
: HTML Tables Don't Know Size of MathML Content
Status: RESOLVED FIXED
: WebKit
WebKit Misc.
: 528+ (Nightly build)
: All Mac OS X 10.5
: P2 Normal
Assigned To:
:
:
:
: 3251
  Show dependency treegraph
 
Reported: 2010-03-24 09:54 PST by
Modified: 2010-07-05 09:26 PST (History)


Attachments
Testcase (5.81 KB, application/xhtml+xml)
2010-06-22 14:10 PST, Jacques Distler
no flags Details


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2010-03-24 09:54:08 PST
Table cells with MathML content are not sized appropriately, so the content overlaps neighbouring cells, or disappears entirely.

See the testcase.
------- Comment #1 From 2010-06-22 13:53:29 PST -------
There is no test case for this bug.  Can you upload an example?
------- Comment #2 From 2010-06-22 13:55:14 PST -------
A quick test of this looks like https://bugs.webkit.org/show_bug.cgi?id=40986 may fix it.

If you have an example with the problem, I can confirm this.
------- Comment #3 From 2010-06-22 14:10:30 PST -------
Created an attachment (id=59414) [details]
Testcase

Damn! What happened to the testcase I uploaded?

I think this is close to the original (hastily-reconstructed).
------- Comment #4 From 2010-06-22 14:42:11 PST -------
It looks like this is fixed by the patch in 40986.
------- Comment #5 From 2010-06-30 01:04:55 PST -------
Indeed, the test case seems to be rendered properly now.

The bug status should be changed to CLOSED.