Bug 36216 - [Qt] GraphicsLayer: support fill-modes
: [Qt] GraphicsLayer: support fill-modes
Status: CLOSED FIXED
Product: WebKit
Classification: Unclassified
Component: Layout and Rendering
: 528+ (Nightly build)
: All All
: P3 Normal
Assigned To: Noam Rosenthal
: Qt
Depends on: 37746
Blocks: 36191
  Show dependency treegraph
 
Reported: 2010-03-17 06:00 PDT by Noam Rosenthal
Modified: 2010-04-20 13:05 PDT (History)
10 users (show)

See Also:


Attachments
implemet fill modes in GraphicsLayerQt (6.52 KB, patch)
2010-04-16 16:23 PDT, Noam Rosenthal
no flags Details | Formatted Diff | Diff
removed unnecessary function (6.20 KB, patch)
2010-04-16 16:37 PDT, Noam Rosenthal
no flags Details | Formatted Diff | Diff
re-submitting the patch, this time with a couple of more null-checks I overlooked in the first patch. All the regressed tests worked for me after this patch. (3.92 KB, patch)
2010-04-19 00:07 PDT, Noam Rosenthal
kenneth: review-
commit-queue: commit‑queue-
Details | Formatted Diff | Diff
changelog was mistakenly omitted from previous patch (6.28 KB, patch)
2010-04-19 11:36 PDT, Noam Rosenthal
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Noam Rosenthal 2010-03-17 06:00:38 PDT
fill-modes are a new webkit CSS concept that allows for compound sequential animations.
This needs to be special-cased in GraphicsLayer.

test: LayoutTests/animations/fill-mode-transform.html
Comment 1 Noam Rosenthal 2010-04-16 16:23:14 PDT
Created attachment 53576 [details]
implemet fill modes in GraphicsLayerQt
Comment 2 Antti Koivisto 2010-04-16 16:36:00 PDT
r=me, please remove the unused fillBackwards function
Comment 3 Noam Rosenthal 2010-04-16 16:37:11 PDT
Created attachment 53580 [details]
removed unnecessary function
Comment 4 WebKit Commit Bot 2010-04-16 19:05:00 PDT
Comment on attachment 53580 [details]
removed unnecessary function

Clearing flags on attachment: 53580

Committed r57770: <http://trac.webkit.org/changeset/57770>
Comment 5 WebKit Commit Bot 2010-04-16 19:05:05 PDT
All reviewed patches have been landed.  Closing bug.
Comment 6 WebKit Review Bot 2010-04-16 19:23:32 PDT
http://trac.webkit.org/changeset/57770 might have broken Qt Linux Release
Comment 7 Csaba Osztrogonác 2010-04-16 23:42:41 PDT
(In reply to comment #6)
> http://trac.webkit.org/changeset/57770 might have broken Qt Linux Release
Rollout committed in http://trac.webkit.org/changeset/57776
Comment 8 Csaba Osztrogonác 2010-04-16 23:44:59 PDT
rollout bug: https://bugs.webkit.org/show_bug.cgi?id=37746
crashed caused by the original bug: http://build.webkit.org/results/Qt%20Linux%20Release/r57770%20%2810253%29/results.html

First I tried to do a clean build, but it didn't resolve the crashes,
so I had to rollout the patch.
Comment 9 Eric Seidel 2010-04-18 16:28:28 PDT
Comment on attachment 53576 [details]
implemet fill modes in GraphicsLayerQt

Cleared Antti Koivisto's review+ from obsolete attachment 53576 [details] so that this bug does not appear in http://webkit.org/pending-commit.
Comment 10 Noam Rosenthal 2010-04-19 00:07:37 PDT
Created attachment 53655 [details]
re-submitting the patch, this time with a couple of more null-checks I overlooked in the first patch. All the regressed tests worked for me after this patch.
Comment 11 WebKit Commit Bot 2010-04-19 09:32:01 PDT
Comment on attachment 53655 [details]
re-submitting the patch, this time with a couple of more null-checks I overlooked in the first patch. All the regressed tests worked for me after this patch.

Rejecting patch 53655 from commit-queue.

Found no modified ChangeLogs, cannot create a commit message.
All changes require a ChangeLog.  See:
http://webkit.org/coding/contributing.html
Comment 12 Kenneth Rohde Christiansen 2010-04-19 10:35:11 PDT
You are right, how could I have missed that :-(. I will r- it for that reason.
Comment 13 Csaba Osztrogonác 2010-04-19 11:04:30 PDT
(In reply to comment #10)
> Created an attachment (id=53655) [details]
> re-submitting the patch, this time with a couple of more null-checks I
> overlooked in the first patch. All the regressed tests worked for me after this
> patch.

I tested it on bot, it will work without crashes.
Comment 14 Noam Rosenthal 2010-04-19 11:36:24 PDT
Created attachment 53695 [details]
changelog was mistakenly omitted from previous patch
Comment 15 WebKit Commit Bot 2010-04-20 01:28:11 PDT
Comment on attachment 53695 [details]
changelog was mistakenly omitted from previous patch

Clearing flags on attachment: 53695

Committed r57878: <http://trac.webkit.org/changeset/57878>
Comment 16 WebKit Commit Bot 2010-04-20 01:28:18 PDT
All reviewed patches have been landed.  Closing bug.
Comment 17 Simon Hausmann 2010-04-20 13:05:19 PDT
Revision r57878 cherry-picked into qtwebkit-2.0 with commit 6b307dc15ad5180ba95bb97df76f0cfcc2e8bf22