PopupMenuClient class is the interface used by combobox popup implementations. It needs to be extended to handle <select multiple> needs.
Created attachment 50833 [details] patch 1
+ Document* doc = static_cast<Element*>(node())->document(); no need to cast here, luiz: node()->document() +if (!doc || doc != doc->frame()->document()) that looks odd :)
Remove [Qt] from title as this patch doesn't even touch Qt code. Add Qt as keyword so that it shows up in our filters
Created attachment 51046 [details] patch 2
Created attachment 51055 [details] patch 3
Comment on attachment 51055 [details] patch 3 Let's call it ListPopupMenuClient instead of just ListPopupClient. I think you should wrap all the code in this patch inside #if ENABLE(NO_LISTBOX_RENDERING). That will help people understand that this is unique to that feature. Everything else looks fine.
Created attachment 51105 [details] patch 4
Comment on attachment 51105 [details] patch 4 Looks good, r=me
Comment on attachment 51105 [details] patch 4 Clearing flags on attachment: 51105 Committed r56285: <http://trac.webkit.org/changeset/56285>
All reviewed patches have been landed. Closing bug.