Bug 36052 - [Qt] REGRESSION(55878) 63 test cases crash
Summary: [Qt] REGRESSION(55878) 63 test cases crash
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: 528+ (Nightly build)
Hardware: PC Linux
: P3 Blocker
Assignee: Nobody
URL:
Keywords: Qt
Depends on:
Blocks:
 
Reported: 2010-03-12 05:46 PST by Csaba Osztrogonác
Modified: 2010-03-12 13:38 PST (History)
4 users (show)

See Also:


Attachments
gdb backtrace: editing/deleting/5290534.html (8.12 KB, text/plain)
2010-03-12 05:46 PST, Csaba Osztrogonác
no flags Details
gdb backtrace: fast/events/key-events-in-input-text.html (9.83 KB, text/plain)
2010-03-12 05:47 PST, Csaba Osztrogonác
no flags Details
gdb backtrace: fast/forms/8250.html (8.38 KB, text/plain)
2010-03-12 05:47 PST, Csaba Osztrogonác
no flags Details
gdb backtrace: http/tests/navigation/anchor-basic.html (1.51 KB, text/plain)
2010-03-12 05:48 PST, Csaba Osztrogonác
no flags Details
Patch for testing! (1.38 KB, patch)
2010-03-12 09:50 PST, Gavin Barraclough
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Csaba Osztrogonác 2010-03-12 05:46:00 PST
Created attachment 50586 [details]
gdb backtrace: editing/deleting/5290534.html

commit: http://trac.webkit.org/changeset/55878
original bug: https://bugs.webkit.org/show_bug.cgi?id=36041
Comment 1 Csaba Osztrogonác 2010-03-12 05:47:07 PST
Created attachment 50587 [details]
gdb backtrace: fast/events/key-events-in-input-text.html
Comment 2 Csaba Osztrogonác 2010-03-12 05:47:49 PST
Created attachment 50588 [details]
gdb backtrace: fast/forms/8250.html
Comment 3 Csaba Osztrogonác 2010-03-12 05:48:22 PST
Created attachment 50589 [details]
gdb backtrace: http/tests/navigation/anchor-basic.html
Comment 4 Csaba Osztrogonác 2010-03-12 05:53:51 PST
I attached four gdb backtrace. Have you got any idea how are these crashes related to UStringImpl patch and how to fix them?
Comment 5 Gavin Barraclough 2010-03-12 09:50:01 PST
Hi Csaba,

Any chance you could test a change for me please, to see if it helps?

My guess is that the bug is that the QTextBoundaryFinder may be assuming that all non-null strings are at least one character long? – this patch changed empty()->characters() from 0 to 1 so that String("").characters() is distinct from String().characters().

It looks like the problem is in platform/text/qt/TextBreakIteratorQt.cpp, I'll attach a patch that should hopefully fix the issue for you.

apologies for the breakage, and thanks in advance,
G.
Comment 6 Gavin Barraclough 2010-03-12 09:50:39 PST
Created attachment 50604 [details]
Patch for testing!
Comment 7 Csaba Osztrogonác 2010-03-12 10:23:45 PST
(In reply to comment #6)
> Created an attachment (id=50604) [details]
> Patch for testing!

I tested this patch, it fixes all crashes. Thanks for your help.
Comment 8 Gavin Barraclough 2010-03-12 12:08:48 PST
Awesome, cheers Ossy, just heading into the office, will get this reviewed & landed when I get there.
Thanks for testing, & apologies again for the breakage.
G.
Comment 9 Gavin Barraclough 2010-03-12 13:38:19 PST
r+ in person from ggaren, fix landed in r55934.