Bug 35731 - [ES6] Implement Proxies
: [ES6] Implement Proxies
Status: RESOLVED FIXED
Product: WebKit
Classification: Unclassified
Component: JavaScriptCore
: 528+ (Nightly build)
: All All
: P2 Normal
Assigned To: Saam Barati
:
Depends on: 154081 154313 154314 154321
Blocks: 80559
  Show dependency treegraph
 
Reported: 2010-03-04 02:58 PST by Oliver Hunt
Modified: 2016-11-16 09:22 PST (History)
14 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Comment 1 Timothy Hatcher 2015-12-03 12:14:07 PST
*** Bug 151578 has been marked as a duplicate of this bug. ***
Comment 2 stefano.dipaola 2016-11-16 01:05:50 PST
By now Proxies have been implemented on all major browsers..

What is the current status of this bug?

Is there a public experimental branch? 

Is there any commitment on seriously porting Proxy on WebKit?

Thanks
Comment 3 Saam Barati 2016-11-16 09:13:36 PST
(In reply to comment #2)
> By now Proxies have been implemented on all major browsers..
> 
> What is the current status of this bug?
> 
> Is there a public experimental branch? 
> 
> Is there any commitment on seriously porting Proxy on WebKit?
> 
> Thanks

Proxy has been in WebKit for ~6 months now.
Comment 4 stefano.dipaola 2016-11-16 09:22:27 PST
(In reply to comment #3)
> (In reply to comment #2)
> > By now Proxies have been implemented on all major browsers..
> > 
> > What is the current status of this bug?
> > 
> > Is there a public experimental branch? 
> > 
> > Is there any commitment on seriously porting Proxy on WebKit?
> > 
> > Thanks
> 
> Proxy has been in WebKit for ~6 months now.

Ah awesome, I relied on the Status and I didn't actually check sorry :)

Thanks then!