Bug 154321 - [ES6] Implement revocable proxies
Summary: [ES6] Implement revocable proxies
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: JavaScriptCore (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Saam Barati
URL:
Keywords:
: 155135 (view as bug list)
Depends on:
Blocks: 35731
  Show dependency treegraph
 
Reported: 2016-02-16 18:36 PST by Saam Barati
Modified: 2016-03-07 23:16 PST (History)
11 users (show)

See Also:


Attachments
patch (35.73 KB, patch)
2016-03-07 18:19 PST, Saam Barati
no flags Details | Formatted Diff | Diff
patch (36.23 KB, patch)
2016-03-07 18:35 PST, Saam Barati
mark.lam: review+
Details | Formatted Diff | Diff
patch for landing (36.25 KB, patch)
2016-03-07 20:03 PST, Saam Barati
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Saam Barati 2016-02-16 18:36:28 PST
...
Comment 1 Saam Barati 2016-03-07 18:14:43 PST
*** Bug 155135 has been marked as a duplicate of this bug. ***
Comment 2 Saam Barati 2016-03-07 18:19:15 PST
Created attachment 273255 [details]
patch
Comment 3 Saam Barati 2016-03-07 18:35:02 PST
Created attachment 273257 [details]
patch
Comment 4 Mark Lam 2016-03-07 19:45:34 PST
Comment on attachment 273257 [details]
patch

View in context: https://bugs.webkit.org/attachment.cgi?id=273257&action=review

r=me

> Source/JavaScriptCore/CMakeLists.txt:767
> +    runtime/ProxyRevoke.cpp

I think you'll also need to add the new files to the vcproj build files.  I thought Alex removed them already, but a quick check shows that they are still in the repo.
Comment 5 Saam Barati 2016-03-07 20:03:20 PST
Created attachment 273262 [details]
patch for landing

lets see if this fixes the build.
Comment 6 WebKit Commit Bot 2016-03-07 23:16:10 PST
Comment on attachment 273262 [details]
patch for landing

Clearing flags on attachment: 273262

Committed r197732: <http://trac.webkit.org/changeset/197732>
Comment 7 WebKit Commit Bot 2016-03-07 23:16:14 PST
All reviewed patches have been landed.  Closing bug.