Bug 34443 - [GTK] Crash on testwebbackforwardlist unit test
Summary: [GTK] Crash on testwebbackforwardlist unit test
Status: RESOLVED DUPLICATE of bug 34444
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKitGTK (show other bugs)
Version: 528+ (Nightly build)
Hardware: PC Linux
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-02-01 12:15 PST by Gustavo Noronha (kov)
Modified: 2010-02-01 13:24 PST (History)
2 users (show)

See Also:


Attachments
Stack trace of the crash (4.01 KB, text/plain)
2010-02-01 12:15 PST, Gustavo Noronha (kov)
no flags Details
Add missing null-check (2.13 KB, patch)
2010-02-01 12:19 PST, Gustavo Noronha (kov)
beidson: review-
gns: commit-queue-
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Gustavo Noronha (kov) 2010-02-01 12:15:09 PST
Created attachment 47861 [details]
Stack trace of the crash

This is crashing since r53950 - reverting that revision fixes the crash. Trace attached.
Comment 1 Gustavo Noronha (kov) 2010-02-01 12:19:20 PST
Created attachment 47862 [details]
Add missing null-check
Comment 2 Brady Eidson 2010-02-01 12:33:09 PST
Comment on attachment 47862 [details]
Add missing null-check

Please hold off on this - we need a more complete fix.  (This is not GTK-only)

See https://bugs.webkit.org/show_bug.cgi?id=34444
Comment 3 Brady Eidson 2010-02-01 12:33:58 PST
Reverse duping because 34444 has a more complete fix.

*** This bug has been marked as a duplicate of bug 34444 ***
Comment 4 Brady Eidson 2010-02-01 12:35:13 PST
Also, sorry for the reverse dupe.  I'd actually been working on this crash for the last few hours (oh what fun adding DRT changes and tests for specific API usage...) and filed 34444 before I saw this existed.  What a difference 10 minutes makes.
Comment 5 Gustavo Noronha (kov) 2010-02-01 13:24:51 PST
(In reply to comment #4)
> Also, sorry for the reverse dupe.  I'd actually been working on this crash for
> the last few hours (oh what fun adding DRT changes and tests for specific API
> usage...) and filed 34444 before I saw this existed.  What a difference 10
> minutes makes.

Nevermind, I made a simple fix because this would hold up our release, I'm happy to see a much more solid fix landing, thanks!