Bug 33446 - REGRESSION(r52948): JavaScript exceptions thrown on Google Maps when getting directions for a second time
Summary: REGRESSION(r52948): JavaScript exceptions thrown on Google Maps when getting ...
Status: RESOLVED DUPLICATE of bug 31871
Alias: None
Product: WebKit
Classification: Unclassified
Component: JavaScriptCore (show other bugs)
Version: 528+ (Nightly build)
Hardware: PC OS X 10.6
: P1 Normal
Assignee: Nobody
URL:
Keywords: InRadar, NeedsReduction, Regression
Depends on:
Blocks:
 
Reported: 2010-01-09 21:51 PST by Mark Rowe (bdash)
Modified: 2010-01-15 12:51 PST (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mark Rowe (bdash) 2010-01-09 21:51:56 PST
Steps to reproduce:
1) Load <http://maps.google.co.nz/> and search for Auckland.
2) Click “Get Directions”.
3) Enter “Taupo” in to the empty field and press “Get Directions”.
4) Press “Get Directions” a second time.

You’ll notice after step three that directions are displayed.  After step four the directions will no longer be visible and the yellow “Loading…” indicator will remain at the top of the screen.
Comment 1 Mark Rowe (bdash) 2010-01-09 21:52:26 PST
<rdar://problem/7527346>
Comment 2 Mark Rowe (bdash) 2010-01-09 21:53:45 PST
I should probably mention the JavaScript exception that I see logged in the console:

TypeError: Result of expression 'a.lng' [undefined] is not a function. (main.js:709)
Comment 3 Geoffrey Garen 2010-01-11 18:57:19 PST
This bug seems to be reproducible getting directions on any google maps property going from anywhere to anywhere.

Another symptom is that the blue line of travel never shows up on the map.
Comment 4 Geoffrey Garen 2010-01-11 19:00:25 PST
Shorter steps to reproduce: Load this URL: http://maps.google.com/maps?f=d&hl=en&geocode=&saddr=cupertino&daddr=berkeley.
Comment 5 Geoffrey Garen 2010-01-15 12:50:38 PST
Committed r53341: <http://trac.webkit.org/changeset/53341>
Comment 6 Geoffrey Garen 2010-01-15 12:51:00 PST

*** This bug has been marked as a duplicate of bug 31871 ***