Bug 31871 - REGRESSION (r50704): Incorrect property caching due to flattenDictionaryStructure (breaks google maps)
Summary: REGRESSION (r50704): Incorrect property caching due to flattenDictionaryStruc...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Layout and Rendering (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh PowerPC OS X 10.5
: P1 Normal
Assignee: Nobody
URL: http://maps.google.com
Keywords: InRadar, Regression
: 33446 (view as bug list)
Depends on:
Blocks:
 
Reported: 2009-11-25 07:12 PST by koenvanderdrift
Modified: 2010-04-23 14:52 PDT (History)
3 users (show)

See Also:


Attachments
Patch (12.94 KB, patch)
2010-01-15 12:14 PST, Geoffrey Garen
oliver: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description koenvanderdrift 2009-11-25 07:12:08 PST
When loading a Google maps page, many of the buttons in the map view are shifted around and/or not working. For instance, the street view puppet is not usable, and even disappears from the screen. This only occurs with the recent nightly builds since about 2 weeks. The regualr Safari 4.0.4 does not do this and Google maps works as expected.
Comment 1 fabien.coeurjoly 2009-12-10 08:35:19 PST
I can confirm this bug on a PowerPC machine too. This bug has been introduced recently, and apparently it seems to happen when JIT is disabled (which is obviously the case on PPC architecture). The bug can also be reproduced on x86 when JIT is disabled.
Comment 2 Alexey Proskuryakov 2009-12-10 14:13:39 PST
See also: bug 32153.
Comment 3 Alexey Proskuryakov 2009-12-10 14:15:01 PST
<rdar://problem/7461971>
Comment 4 Geoffrey Garen 2010-01-15 12:14:14 PST
Created attachment 46696 [details]
Patch
Comment 5 Oliver Hunt 2010-01-15 12:16:03 PST
Comment on attachment 46696 [details]
Patch

r=me, assuming no perf hit
Comment 6 Geoffrey Garen 2010-01-15 12:49:14 PST
Committed r53341: <http://trac.webkit.org/changeset/53341>
Comment 7 Geoffrey Garen 2010-01-15 12:51:00 PST
*** Bug 33446 has been marked as a duplicate of this bug. ***