Bug 32543 - REGRESSION(52026): 14 JSC regressions with interpreter
Summary: REGRESSION(52026): 14 JSC regressions with interpreter
Status: RESOLVED DUPLICATE of bug 32498
Alias: None
Product: WebKit
Classification: Unclassified
Component: JavaScriptCore (show other bugs)
Version: 528+ (Nightly build)
Hardware: PC All
: P2 Normal
Assignee: Nobody
URL:
Keywords: InRadar, Regression
Depends on:
Blocks:
 
Reported: 2009-12-15 02:22 PST by Csaba Osztrogonác
Modified: 2009-12-15 16:38 PST (History)
4 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Csaba Osztrogonác 2009-12-15 02:22:19 PST
http://trac.webkit.org/changeset/52026 caused 14 JSC regressions 
with interpreter build (ENABLE_JIT=0, ENABLE_YARR_JIT=0). It was
tested on x86 and on ARM platforms too.

Detailed results:
--
** Danger, Will Robinson! Danger! The following failures have been introduced:
        ecma/Array/15.4.2.1-2.js
        ecma/Array/15.4.2.1-3.js
        ecma/Array/15.4.4.3-1.js
        ecma/Expressions/11.6.1-3.js
        ecma/GlobalObject/15.1.2.4.js
        ecma/GlobalObject/15.1.2.5-1.js
        ecma/GlobalObject/15.1.2.5-2.js
        ecma/GlobalObject/15.1.2.5-3.js
        ecma/String/15.5.3.2-2.js
        ecma_2/Statements/try-004.js
        ecma_2/Statements/try-005.js
        ecma_3/String/regress-104375.js
        js1_5/Object/regress-90596-003.js
        js1_5/Regress/regress-39309.js

14 regressions found.
0 tests fixed.
Comment 1 Alexey Proskuryakov 2009-12-15 12:16:15 PST
<rdar://problem/7473274>
Comment 2 Alexey Proskuryakov 2009-12-15 13:00:40 PST
Do these all have a common cause? Bug 32498 is a real world example of an issue, but I'm not sure if I should just dupe this to it.
Comment 3 Alexey Proskuryakov 2009-12-15 16:38:00 PST
Bug 32498 fixed all of these.

*** This bug has been marked as a duplicate of bug 32498 ***