Bug 32498 - REGRESSION(r51978-r52039): AJAX "Mark This Forum Read" function no longer works
Summary: REGRESSION(r51978-r52039): AJAX "Mark This Forum Read" function no longer works
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: JavaScriptCore (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh PowerPC OS X 10.5
: P1 Normal
Assignee: Nobody
URL: http://www.mania.com/aodvb/forumdispl...
Keywords: InRadar, Regression
: 32543 (view as bug list)
Depends on:
Blocks:
 
Reported: 2009-12-13 15:28 PST by Kevin M. Dean
Modified: 2010-01-19 13:11 PST (History)
3 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Kevin M. Dean 2009-12-13 15:28:49 PST
When logged in on a vBulletin forum like the one at mania.com, select the Forum Tools menu and choose "Mark This Forum Read". Any unread threads should switch from bolded text (unread) to plain text (read).

Under r51978, this works and the console says:

XHR finished loading: "http://www.mania.com/aodvb/ajax.php?do=markread&f=30".

Under r52039, nothing happens and the console says:

XHR finished loading: "http://www.mania.com/aodvb/30".

Notice a good portion of the correct link is missing on the failing result.
Comment 1 Alexey Proskuryakov 2009-12-14 17:31:15 PST
Confirmed with r52124 on PowerPC. Works fine on Intel.
Comment 2 Alexey Proskuryakov 2009-12-14 17:31:41 PST
<rdar://problem/7471495>
Comment 3 Alexey Proskuryakov 2009-12-15 10:15:52 PST
Reduction: alert('a' + 1) gives '1'.
Comment 4 Geoffrey Garen 2009-12-15 16:05:09 PST
Committed revision 52182.
Comment 5 Alexey Proskuryakov 2009-12-15 16:38:00 PST
*** Bug 32543 has been marked as a duplicate of this bug. ***
Comment 6 Kevin M. Dean 2010-01-19 08:16:38 PST
I'm not sure if this is completely fixed after all. I'm still seeing some issues that I can trace back to the same build number for when the problem starts. Check out this other bug to see if it's related to the same thing.

https://bugs.webkit.org/show_bug.cgi?id=33383
Comment 7 Geoffrey Garen 2010-01-19 12:33:55 PST
(In reply to comment #6)
Probably not the exact same problem, since this particular bug was a simple typo.
Comment 8 Kevin M. Dean 2010-01-19 13:11:33 PST
(In reply to comment #7)

Sure, I wouldn't think it's the exact problem either, but I thought it might be related to the same initial changes that came with the build that has caused both issues to begin occurring. I haven't been able to reliably use a Webkit build since early December due to this and I'm concerned.