Bug 3232 - CSS2: Web Kit does not support all list style types
Summary: CSS2: Web Kit does not support all list style types
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: CSS (show other bugs)
Version: 412
Hardware: Macintosh OS X 10.4
: P2 Normal
Assignee: Darin Adler
URL: http://www.w3.org/International/tests...
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2005-06-01 14:40 PDT by Dave Hyatt
Modified: 2007-01-08 14:50 PST (History)
6 users (show)

See Also:


Attachments
patch -- should also turn the test page into one or more WebKit tests (4.88 KB, patch)
2007-01-06 16:47 PST, Darin Adler
mjs: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Dave Hyatt 2005-06-01 14:40:25 PDT
Safari fails several cases of the W3C list-style-type test.

* STEPS TO REPRODUCE
1. 10.3.3, Safari 1.2.1
2. Go to http://www.w3.org/International/tests/sec-list-style-type-1.html

* RESULTS
Safari fails the following tests:
hiragana
hiragana-iroha
katakana
katakana-iroha
cjk-ideographic
georgian
armenian

* NOTES
We'll need to do some research on the last three.
Comment 1 Dave Hyatt 2005-06-01 14:42:50 PDT
Apple Bug: rdar://3611345/
Comment 2 Nicholas Shanks 2005-06-16 09:43:14 PDT
I have a KDE merge in the works for this, should be ready in a day or two (depending on how other 
patches are going).
Comment 3 Eric Seidel (no email) 2005-12-28 01:58:01 PST
Nick, any news on the merge patches from kde?
Comment 4 Eric Seidel (no email) 2005-12-28 01:58:30 PST
Adding mitz and ap, as this is an internationalization issue they might have interest in.
Comment 5 Alexey Proskuryakov 2005-12-28 04:41:59 PST
Hmm, looks like even CSS3 draft still doesn't list Russian as a possible list-style-type: <http://
www.w3.org/TR/2002/WD-css3-lists-20021107/>. See also: <http://www.ethiopic.org/w3c/css/WD-
css3-lists-20020220-comments.html> (I don't know whether this public note has had any effect).
Comment 6 Alexey Proskuryakov 2007-01-06 14:59:18 PST
After r18637, the results mostly match Firefox, with the following differences:

1) cjk-ideographic results look quite broken;
2) hebrew RTL rendering is different (can't tell which is correct).
Comment 7 Darin Adler 2007-01-06 16:42:56 PST
I have a patch to get us the rest of the way.
Comment 8 Darin Adler 2007-01-06 16:47:17 PST
Created attachment 12269 [details]
patch -- should also turn the test page into one or more WebKit tests
Comment 9 Maciej Stachowiak 2007-01-06 18:16:48 PST
Comment on attachment 12269 [details]
patch -- should also turn the test page into one or more WebKit tests

r=me

Make sure to land the test case with this.
Comment 10 Darin Adler 2007-01-06 20:45:08 PST
I don't want to check this fix in until the test improvements from bug 12412, since the test case is too big for a pixel test to cover it well, and unless there are list markers in the render tree dump it won't be a helpful test.
Comment 11 David Kilzer (:ddkilzer) 2007-01-06 22:10:49 PST
(In reply to comment #10)
> I don't want to check this fix in until the test improvements from bug 12412,

That's actually Bug 12142.
Comment 12 Sam Weinig 2007-01-08 14:50:30 PST
Landed in r18671.