Bug 32256 - Google reader gets stuck in the "Loading..." state and does not complete
Summary: Google reader gets stuck in the "Loading..." state and does not complete
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Page Loading (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh Intel OS X 10.6
: P2 Normal
Assignee: Nobody
URL: http://www.google.com/reader/view
Keywords:
: 32329 32342 (view as bug list)
Depends on:
Blocks:
 
Reported: 2009-12-07 16:40 PST by sjlee0
Modified: 2009-12-09 23:48 PST (History)
12 users (show)

See Also:


Attachments
screenshot (91.82 KB, image/png)
2009-12-07 16:40 PST, sjlee0
no flags Details
Patch (4.81 KB, patch)
2009-12-09 23:29 PST, Maciej Stachowiak
oliver: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description sjlee0 2009-12-07 16:40:04 PST
Starting build 51788, the Google Reader page gets stuck while rendering the main list area.  A screenshot is attached.  Clearing cache doesn't help.
Comment 1 sjlee0 2009-12-07 16:40:57 PST
Created attachment 44447 [details]
screenshot
Comment 2 mlaster 2009-12-08 08:22:50 PST
I'm seeing this behavior too in r51825.
Comment 3 Bill Rodriguez 2009-12-08 08:58:16 PST
I am experiencing this..  I have removed all plugins and reset everything and it still isn't working..
Comment 4 Marcus Cavanaugh 2009-12-08 11:34:39 PST
Same problem here. Web Inspecter reveals the following:

File/Line:  /reader/ui/1352531699-en-scroll.js?hl=en:81
NOT_FOUND_ERR: DOM Exception 8: An attempt was made to reference a Node in a context where it does not exist.
Comment 5 Adam Turetzky 2009-12-08 19:36:56 PST
I'm experiencing this too with build 51881 and it started a few builds ago in the last 24 hours.

The same thing is happening when trying to access the Google Voice as well. It won't load the main table area but instead gets stuck with only part of the header and sidebar loaded.
Comment 6 Mihai Parparita 2009-12-08 19:42:16 PST
(I'm a Google Reader engineer)

I can reproduce this with r51881 on Snow Leopard (10.6.2). I was not able to
reproduce with Leopard (10.5.8) on a the same WebKit release.

The error described by Marcus appears to occur within the Closure library, so
it's possible to see the unobfuscated code:

http://code.google.com/p/closure-library/source/browse/trunk/closure/goog/dom/dom.js#657

child in this case is an empty NodeList, which I can see how it would throw an
exception if you tried to append it to an element. At that same code path,
Safari 4.0.4 doesn't seem to end up with a NodeList, but with an (empty)
string.

Let me know if you need more details to track this down.
Comment 7 sjlee0 2009-12-08 21:32:07 PST
I also noticed Gmail's "Move to" and the "Labels" buttons are not working (the menu doesn't drop down on click).

I suspect this might be a related issue.  The error console says

"NOT_FOUND_ERR: DOM Exception 8: An attempt was made to reference a Node in a context where it does not exist."
Comment 8 Bill Rodriguez 2009-12-09 06:43:52 PST
Just to add to the gMail comment you also can't use the Image Upload feature..
Comment 9 nate.barham 2009-12-09 07:55:15 PST
This problem persists in r51881 under Snow Leopard.
Comment 10 sjlee0 2009-12-09 11:08:24 PST

    
Comment 11 Shawn Wilton 2009-12-09 12:03:00 PST
I'm having the same issue.  Stuck at loading.  This is also happening on google calendar when you try to add a new event.
Comment 12 Maciej Stachowiak 2009-12-09 22:57:41 PST
<rdar://problem/7456388>
Comment 13 Maciej Stachowiak 2009-12-09 22:58:14 PST
*** Bug 32329 has been marked as a duplicate of this bug. ***
Comment 14 Maciej Stachowiak 2009-12-09 23:01:07 PST
*** Bug 32342 has been marked as a duplicate of this bug. ***
Comment 15 Maciej Stachowiak 2009-12-09 23:29:57 PST
Created attachment 44594 [details]
Patch
Comment 16 Maciej Stachowiak 2009-12-09 23:48:06 PST
Committed r51939: <http://trac.webkit.org/changeset/51939>