Bug 31786 - FKA: Cannot play/pause on HTML5 video & audio element
Summary: FKA: Cannot play/pause on HTML5 video & audio element
Status: RESOLVED DUPLICATE of bug 117857
Alias: None
Product: WebKit
Classification: Unclassified
Component: Accessibility (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh Intel OS X 10.6
: P2 Normal
Assignee: Deepak Sherveghar
URL: http://yves.vg/testcases/webkit/video...
Keywords:
Depends on: 67190
Blocks:
  Show dependency treegraph
 
Reported: 2009-11-22 10:18 PST by Yves Van Goethem
Modified: 2013-10-23 16:12 PDT (History)
8 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Yves Van Goethem 2009-11-22 10:18:07 PST
I tested this on Firefox, the latest WebKit nightly, Safari 4.0.4 and a Chrome preview.

1. Go to the attached URL
2. Hit the TAB key to access a video element
3. Try to use the spacebar to play/pause a video/audio

Shouldn't this work ? Especially because once you launch the full-screen mode you can use the spacebar to play/pause.
It works as described in Firefox.

Also the W3C Draft categorizes video and audio in "Interactive Content" : http://www.w3.org/TR/html5/embedded-content-0.html#interactive-content
Comment 1 Alexey Proskuryakov 2010-05-21 15:15:34 PDT
Looks like there are two separate issues in this test case:
1) A <video> without tabindex cannot be selected with keyboard or mouse.
2) Even when a <video> element is selected, space bar doesn't start/pause.

This bug report is specifically about #2. Is there a bug filed for #1?
Comment 2 Yves Van Goethem 2010-05-21 15:42:15 PDT
Both are linked by the specification of Interactive Content, having only one of these functionalities wouldn't be sticking to the spec.
Perhaps we should rename the bug either than splitting into two different entries ?

However it would be great if somebody could work on this problems.
Comment 3 Alexey Proskuryakov 2010-05-21 15:58:57 PDT
It's likely that fixes will be in different code areas, and written by different people. Please file a separate bug.
Comment 4 Antonio Gomes 2011-09-14 16:11:40 PDT
Old title:

- [Keyboard] Can't focus and play/pause on HTML5 video & audio element

New title:

- [Keyboard] Can not play/pause on HTML5 video & audio element

The "Can't focus on video & audio element" part is being covered by bug 67190.
Comment 5 James Craig 2013-09-30 12:45:34 PDT
Related to bug 117857
Comment 6 James Craig 2013-10-23 16:12:21 PDT
Duping out to 117857 since there is a proposed fix and the scope of the other includes this issue.

*** This bug has been marked as a duplicate of bug 117857 ***