Bug 31294 - [Qt] Font selection of generic fonts is broken
: [Qt] Font selection of generic fonts is broken
Status: RESOLVED FIXED
: WebKit
Text
: 528+ (Nightly build)
: All Mac OS X 10.5
: P3 Normal
Assigned To:
:
: Qt
:
:
  Show dependency treegraph
 
Reported: 2009-11-10 08:02 PST by
Modified: 2010-01-14 08:06 PST (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2009-11-10 08:02:31 PST
The Qt port does not correctly choose the fonts specified in HTML/CSS.

This is a placeholder bug that we classify as showstopper for Qt 4.6.
------- Comment #1 From 2009-11-10 08:07:35 PST -------
In FontCache::getCachedFontPlatformData() we ignore the family argument which contains the resolved real font family from the web settings, and instead we pass on the generic font family to Qt. 

See also http://www.w3.org/TR/CSS2/fonts.html#generic-font-families

Quick fix here: http://gist.github.com/230871

Will try patch against 4.5 first to not mess up the buildbot too much.
------- Comment #2 From 2009-11-23 05:31:36 PST -------
I believe this may be the same as bug #22896
------- Comment #3 From 2009-11-25 06:52:04 PST -------
*** Bug 22896 has been marked as a duplicate of this bug. ***
------- Comment #4 From 2009-12-21 04:24:17 PST -------
This was fixed in r51758
------- Comment #5 From 2010-01-14 08:06:00 PST -------
*** Bug 29458 has been marked as a duplicate of this bug. ***