Bug 22896 - [Qt] contents of <pre> element not rendered in monospace
: [Qt] contents of <pre> element not rendered in monospace
Status: RESOLVED DUPLICATE of bug 31294
: WebKit
Layout and Rendering
: 528+ (Nightly build)
: Other Linux
: P2 Normal
Assigned To:
:
: Qt
:
:
  Show dependency treegraph
 
Reported: 2008-12-16 18:39 PST by
Modified: 2009-11-25 06:52 PST (History)


Attachments
HTML file demonstrating the problem described (635 bytes, text/html)
2008-12-16 18:42 PST, Michael[tm] Smith
no flags Details
PNG file showing rendering in my environment (22.43 KB, image/png)
2008-12-16 18:42 PST, Michael[tm] Smith
no flags Details
image generated using Ariya's webcapture tool (8.48 KB, image/png)
2009-03-12 23:07 PST, Michael[tm] Smith
no flags Details


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2008-12-16 18:39:54 PST
I'm seeing some weird behavior in my environment (Debian testing with KDE 3.5) with Arora built against a recent Qt 4.5 + QtWebKit snaphot. A demo of the problem is here:

http://www.w3.org/2008/12/pre-test.html

An image of how that page renders in my environment is here:

http://www.w3.org/2008/12/pre-test.html.png

The specific problem is that he contents of a plain <pre> element don't get rendered in monospace (see the first paragraph). If I do <pre class="style="font-family: Courier, monospace">, it seems to show  up on Courier as expected, but with italic and bold. However, if I do <pre class="style="font-family: Bitstream Vera Sans Mono, monospace">, it shows up correctly (monospace without any bold or italic).

I pinged Ben Meyer about this on #arora and he seemed to indicate that he didn't reckon this to be an Arora-specific bug (but instead I guess a QtWebKit bug), so I'm raising it here.
------- Comment #1 From 2008-12-16 18:42:11 PST -------
Created an attachment (id=26082) [details]
HTML file demonstrating the problem described
------- Comment #2 From 2008-12-16 18:42:58 PST -------
Created an attachment (id=26083) [details]
PNG file showing rendering in my environment
------- Comment #3 From 2009-03-12 23:07:03 PST -------
Created an attachment (id=28571) [details]
image generated using Ariya's webcapture tool

The pre-test.html-webcapture.png image was generated using a Qt 4.5 build of Ariya Hidayat's  "webcapture" tool. http://labs.trolltech.com/blogs/2009/01/15/capturing-web-pages/

It's looks pretty much identical to the rendering I get from Arora, so it does seem like this is some problem with QtWebKit in my environment.
------- Comment #4 From 2009-05-22 12:19:32 PST -------
I believe this is also failing for <tt> and <code> sections.
------- Comment #5 From 2009-09-03 04:04:02 PST -------
Why is this still unconfirmed? The test cases are here and it is clear that it does not work in multiple webkit-based browsers...
------- Comment #6 From 2009-10-06 15:21:41 PST -------
*** Bug 30075 has been marked as a duplicate of this bug. ***
------- Comment #7 From 2009-11-25 06:52:04 PST -------
This issue currently fixed in Qt 4.6 trunk (src/3rdparty/webkit).

See bug #31294 to know when this will be fixed in WebKit trunk.

*** This bug has been marked as a duplicate of bug 31294 ***