Bug 30951 - Teach git to ignore some files
Summary: Teach git to ignore some files
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Tools / Tests (show other bugs)
Version: 528+ (Nightly build)
Hardware: All All
: P2 Normal
Assignee: Nobody
URL:
Keywords:
: 25841 (view as bug list)
Depends on:
Blocks:
 
Reported: 2009-10-30 01:23 PDT by Adam Barth
Modified: 2009-12-20 07:30 PST (History)
1 user (show)

See Also:


Attachments
Patch v1 (1.28 KB, patch)
2009-10-30 01:25 PDT, Adam Barth
no flags Details | Formatted Diff | Diff
Patch v1 (1.26 KB, patch)
2009-10-30 01:28 PDT, Adam Barth
no flags Details | Formatted Diff | Diff
Patch v1 (914 bytes, patch)
2009-10-30 01:29 PDT, Adam Barth
no flags Details | Formatted Diff | Diff
Patch v1 (922 bytes, patch)
2009-10-30 01:33 PDT, Adam Barth
no flags Details | Formatted Diff | Diff
Patch v1 (933 bytes, patch)
2009-10-30 01:34 PDT, Adam Barth
no flags Details | Formatted Diff | Diff
Patch v1 (975 bytes, patch)
2009-10-30 01:39 PDT, Adam Barth
no flags Details | Formatted Diff | Diff
Patch v1 (930 bytes, patch)
2009-10-30 01:47 PDT, Adam Barth
mrowe: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Adam Barth 2009-10-30 01:23:56 PDT
git clean is a PITA at the moment because it blows away our xcode settings.  Let's add a .gitignore file to make our lives easier.  Patch forthcoming.
Comment 1 Adam Barth 2009-10-30 01:25:40 PDT
Created attachment 42184 [details]
Patch v1
Comment 2 Adam Barth 2009-10-30 01:28:48 PDT
Created attachment 42185 [details]
Patch v1
Comment 3 Adam Barth 2009-10-30 01:29:53 PDT
Created attachment 42186 [details]
Patch v1
Comment 4 Adam Barth 2009-10-30 01:33:57 PDT
Created attachment 42187 [details]
Patch v1
Comment 5 Adam Barth 2009-10-30 01:34:28 PDT
Created attachment 42188 [details]
Patch v1
Comment 6 Adam Barth 2009-10-30 01:39:15 PDT
Created attachment 42190 [details]
Patch v1
Comment 7 Adam Barth 2009-10-30 01:47:34 PDT
Created attachment 42193 [details]
Patch v1
Comment 8 Mark Rowe (bdash) 2009-10-30 01:49:05 PDT
Comment on attachment 42193 [details]
Patch v1

> diff --git a/.gitignore b/.gitignore
> new file mode 100644
> index 0000000..aa7fc51
> --- /dev/null
> +++ b/.gitignore
> @@ -0,0 +1,6 @@
> +*.mode*
> +*.pbxuser
> +*.perspective*
> +*.pyc
> +build/
> +WebKitBuild/

Technically this last one should be /WebKitBuild/ so that it only matches at the root of the repository.
Comment 9 Adam Barth 2009-10-30 01:56:07 PDT
Committed r50325: <http://trac.webkit.org/changeset/50325>
Comment 10 opendarwin 2009-12-20 07:30:57 PST
*** Bug 25841 has been marked as a duplicate of this bug. ***