Bug 30420 - REGRESSION: Flash doesn't load at googlesightseeing.com and at youtube
Summary: REGRESSION: Flash doesn't load at googlesightseeing.com and at youtube
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Plug-ins (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh Intel OS X 10.6
: P1 Normal
Assignee: Nobody
URL: http://googlesightseeing.com/maps?p=9...
Keywords: Regression
: 30455 30481 (view as bug list)
Depends on:
Blocks:
 
Reported: 2009-10-15 18:15 PDT by Mario Gaucher
Modified: 2009-10-17 20:06 PDT (History)
6 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mario Gaucher 2009-10-15 18:15:00 PDT
tested with the latest webkit nightly on Mac OS X 10.6.2
image on the right does not appear at all...

it works fine in Safari (included in Mac OS X) and latest version of Firefox.
Comment 1 Alexey Proskuryakov 2009-10-15 20:06:48 PDT
Confirmed with r49663 nightly on Leopard. The image at the right is actually Flash - and YouTube is broken for me, too.

On both sites, I'm seeing XSSAuditor warnings in console, which may or may not be related.
Comment 2 Daniel Bates 2009-10-15 20:51:46 PDT
Thanks Mario and Alex,

Yes, there are issues with the latest change to the XSSAuditor (related to the patch for bug #27895). I already rolled out the patch in r49668.

(In reply to comment #1)
> Confirmed with r49663 nightly on Leopard. The image at the right is actually
> Flash - and YouTube is broken for me, too.
> 
> On both sites, I'm seeing XSSAuditor warnings in console, which may or may not
> be related.
Comment 3 Adam Barth 2009-10-15 23:40:19 PDT
Dan rolled out the offending patch.
Comment 4 Alexey Proskuryakov 2009-10-16 15:43:34 PDT
*** Bug 30455 has been marked as a duplicate of this bug. ***
Comment 5 Mark Rowe (bdash) 2009-10-17 20:06:16 PDT
*** Bug 30481 has been marked as a duplicate of this bug. ***