Bug 30295 - REGRESSION (r48492): Gmail voice and video chat doesn’t work
Summary: REGRESSION (r48492): Gmail voice and video chat doesn’t work
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Plug-ins (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh OS X 10.6
: P1 Major
Assignee: Nobody
URL:
Keywords: GoogleBug, InRadar, PlatformOnly, Regression
: 30309 (view as bug list)
Depends on:
Blocks:
 
Reported: 2009-10-11 20:06 PDT by mitz
Modified: 2009-10-12 11:56 PDT (History)
2 users (show)

See Also:


Attachments
Fix a typo in ProxyInstance::setFieldValue() (1.25 KB, patch)
2009-10-11 20:35 PDT, mitz
no flags Details | Formatted Diff | Diff
Fix a typo in ProxyInstance::setFieldValue() (3.24 KB, patch)
2009-10-11 21:11 PDT, mitz
darin: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description mitz 2009-10-11 20:06:55 PDT
Gmail’s plug-in-based voice and video chat isn’t working in TOT. To reproduce, download and install the software from <http://mail.google.com/videochat> (you may want to only install GoogleVoiceandVideo.pkg, and not the other pieces), then log-in to Gmail and sign in to chat. There should be a green camera icon next to your name, and when choosing a contact, the “Video & more” menu should include “Start voice chat”. In TOT, instead of the green camera icon there is a green dot, and the voice chat option is not available.
Comment 1 mitz 2009-10-11 20:12:02 PDT
<rdar://problem/7294267>
Comment 2 mitz 2009-10-11 20:22:13 PDT
Caused by <http://trac.webkit.org/changeset/48492>.
Comment 3 mitz 2009-10-11 20:35:21 PDT
Created attachment 41014 [details]
Fix a typo in ProxyInstance::setFieldValue()
Comment 4 mitz 2009-10-11 21:11:43 PDT
Created attachment 41016 [details]
Fix a typo in ProxyInstance::setFieldValue()

Added test case. Apparently, due to testing limitations of out-of-process plug-ins, the fact that eventLoggingEnabled didn’t work didn’t cause any existing test to fail.
Comment 5 Darin Adler 2009-10-11 21:14:20 PDT
Comment on attachment 41016 [details]
Fix a typo in ProxyInstance::setFieldValue()

> +        Test for <rdar://problem/7294267> REGRESSION (r48492): Gmail voice and
> +        video chat doesnât work

Character set joy.

r=me
Comment 6 mitz 2009-10-11 21:18:58 PDT
Fixed in <http://trac.webkit.org/projects/webkit/changeset/49433>.
Comment 7 Mark Rowe (bdash) 2009-10-12 11:56:00 PDT
*** Bug 30309 has been marked as a duplicate of this bug. ***