Bug 30007 - [GStreamer] data: source could also support non-base64 encoded URIs
Summary: [GStreamer] data: source could also support non-base64 encoded URIs
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Media (show other bugs)
Version: 528+ (Nightly build)
Hardware: PC Linux
: P2 Normal
Assignee: Nobody
URL:
Keywords:
: 37564 (view as bug list)
Depends on:
Blocks:
 
Reported: 2009-10-02 01:57 PDT by Sebastian Dröge (slomo)
Modified: 2010-12-10 11:45 PST (History)
7 users (show)

See Also:


Attachments
proposed patch (15.39 KB, patch)
2010-12-10 02:01 PST, Philippe Normand
gns: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Sebastian Dröge (slomo) 2009-10-02 01:57:36 PDT
Hi,
the media player should support non-base64 URIs too. Example use case for this would be plaintext playlists, subtitles, ...

Should be quite easy to add support for that but make sure to convert from text/plain,charset=XYZ to UTF8 before passing to GStreamer.
Comment 1 Sebastian Dröge (slomo) 2010-01-30 01:24:28 PST
This can be fixed by updating the data URI source from gst-plugins-bad GIT btw.

http://cgit.freedesktop.org/gstreamer/gst-plugins-bad/tree/gst/dataurisrc
Comment 2 Philippe Normand 2010-02-15 03:51:59 PST
(In reply to comment #1)
> This can be fixed by updating the data URI source from gst-plugins-bad GIT btw.
> 
> http://cgit.freedesktop.org/gstreamer/gst-plugins-bad/tree/gst/dataurisrc

I can attach a patch but the style will complain big time! 334 errors in the new DataSourceGStreamer.cpp .. what should we do? Updating anyway or just wait next -bad release and bump requirements ?
Comment 3 Philippe Normand 2010-02-15 03:52:31 PST
Gustavo, ^^ ;)
Comment 4 Gustavo Noronha (kov) 2010-02-15 09:04:07 PST
(In reply to comment #2)
> (In reply to comment #1)
> > This can be fixed by updating the data URI source from gst-plugins-bad GIT btw.
> > 
> > http://cgit.freedesktop.org/gstreamer/gst-plugins-bad/tree/gst/dataurisrc
> 
> I can attach a patch but the style will complain big time! 334 errors in the
> new DataSourceGStreamer.cpp .. what should we do? Updating anyway or just wait
> next -bad release and bump requirements ?

Wait for release, and bump requirements sounds like a good idea to me.
Comment 5 Philippe Normand 2010-02-15 09:14:10 PST
(In reply to comment #4)
> (In reply to comment #2)
> > (In reply to comment #1)
> > > This can be fixed by updating the data URI source from gst-plugins-bad GIT btw.
> > > 
> > > http://cgit.freedesktop.org/gstreamer/gst-plugins-bad/tree/gst/dataurisrc
> > 
> > I can attach a patch but the style will complain big time! 334 errors in the
> > new DataSourceGStreamer.cpp .. what should we do? Updating anyway or just wait
> > next -bad release and bump requirements ?
> 
> Wait for release, and bump requirements sounds like a good idea to me.

According to http://gstreamer.freedesktop.org/wiki/ReleasePlanning2010 -bad 0.10.18 should be released next week
Comment 6 Philippe Normand 2010-12-10 02:01:18 PST
Created attachment 76176 [details]
proposed patch
Comment 7 Gustavo Noronha (kov) 2010-12-10 02:05:29 PST
Comment on attachment 76176 [details]
proposed patch

ok!
Comment 8 Philippe Normand 2010-12-10 02:26:37 PST
Committed r73700: <http://trac.webkit.org/changeset/73700>
Comment 9 Philippe Normand 2010-12-10 02:27:25 PST
*** Bug 37564 has been marked as a duplicate of this bug. ***
Comment 10 WebKit Review Bot 2010-12-10 11:45:08 PST
http://trac.webkit.org/changeset/73700 might have broken GTK Linux 32-bit Debug