Bug 29992 - CSS animations don't work on pseudo-elements
Summary: CSS animations don't work on pseudo-elements
Status: RESOLVED DUPLICATE of bug 23209
Alias: None
Product: WebKit
Classification: Unclassified
Component: CSS (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh Intel OS X 10.6
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-10-01 19:11 PDT by Jeffrey Rosen
Modified: 2011-04-15 09:59 PDT (History)
1 user (show)

See Also:


Attachments
This should fade from black to white (431 bytes, text/html)
2009-10-01 19:12 PDT, Jeffrey Rosen
no flags Details
correct attachment (437 bytes, text/html)
2009-10-01 19:15 PDT, Jeffrey Rosen
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jeffrey Rosen 2009-10-01 19:11:16 PDT
CSS animations don't seem to affect pseudo-elements

Attached a simple test case
Comment 1 Jeffrey Rosen 2009-10-01 19:12:10 PDT
Created attachment 40490 [details]
This should fade from black to white
Comment 2 Jeffrey Rosen 2009-10-01 19:15:24 PDT
Created attachment 40491 [details]
correct attachment
Comment 3 Jeffrey Rosen 2009-10-01 19:15:59 PDT
Actually, it seems like any element that has content:'something'; specified will not work.
Comment 4 Simon Fraser (smfr) 2011-04-15 09:59:03 PDT

*** This bug has been marked as a duplicate of bug 23209 ***