The code for dealing with redirect scheduling is a separable concern from the main "loading a frame" task of the FrameLoader. I'm going to take this in baby steps to help make the changes reviewable. Patch forthcoming.
Created attachment 40417 [details]
I should also say that I'll remove the FrameLoader::schedule* methods in a future patch. I didn't want to touch all the clients in this patch.
Can RedirectScheduler go in its own file?
(In reply to comment #3)
> Can RedirectScheduler go in its own file?
Absolutely. I just wanted to make the diff easier to read.
Future patch in https://bugs.webkit.org/show_bug.cgi?id=29950
Comment on attachment 40417 [details]
I suggest removing this comment, we don't need to worry about the next line being removed accidentally since it would break the build:
// We need an explicit dtor because ScheduledRedirection is an incomplete type here.
Committed r48958: <http://trac.webkit.org/changeset/48958>