Bug 29538 - [Qt] Mac OS X: WebKit/JavaScriptCore doesn't respect backward compatibility
Summary: [Qt] Mac OS X: WebKit/JavaScriptCore doesn't respect backward compatibility
Status: RESOLVED DUPLICATE of bug 34888
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKit Misc. (show other bugs)
Version: 528+ (Nightly build)
Hardware: Other OS X 10.5
: P2 Normal
Assignee: Nobody
URL:
Keywords: Qt
Depends on: 29542
Blocks:
  Show dependency treegraph
 
Reported: 2009-09-21 04:55 PDT by Tor Arne Vestbø
Modified: 2010-03-10 04:55 PST (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tor Arne Vestbø 2009-09-21 04:55:06 PDT
This bug report originated from Nokia internal issue QT-675

--- Description ---

By default Qt is compiled with 10.4 compatibility when compiling on Leopard.
WebKit breaks that compatibility, resulting in crashes because mmap fails.
BUILDING_ON_TIGER should be defined depending on configure options.
Comment 1 Tor Arne Vestbø 2010-03-10 04:55:23 PST

*** This bug has been marked as a duplicate of bug 34888 ***