Bug 27582 - [CSS3 Backgrounds and Borders] Add support for inset box shadows
: [CSS3 Backgrounds and Borders] Add support for inset box shadows
Status: RESOLVED FIXED
Product: WebKit
Classification: Unclassified
Component: CSS
: 528+ (Nightly build)
: All All
: P2 Normal
Assigned To: mitz@webkit.org
:
Depends on:
Blocks: 27569
  Show dependency treegraph
 
Reported: 2009-07-22 15:53 PDT by Dave Hyatt
Modified: 2010-02-10 18:18 PST (History)
2 users (show)

See Also:


Attachments
Add support for inset box shadows (123.82 KB, patch)
2009-07-23 15:41 PDT, mitz@webkit.org
hyatt: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Dave Hyatt 2009-07-22 15:53:38 PDT
box-shadow supports an "inset" keyword that indicates the shadow should be inset instead.
Comment 1 mitz@webkit.org 2009-07-23 15:41:47 PDT
Created attachment 33387 [details]
Add support for inset box shadows
Comment 2 Dave Hyatt 2009-07-23 15:51:24 PDT
Comment on attachment 33387 [details]
Add support for inset box shadows

Looks good!  Can you put "inset" first in a couple of the test just to make sure the parsing is covered?

It might not hurt to have a test of inset in between the length and color (and color and length) also, just to show that the entire property gets discarded.

r=me
Comment 3 mitz@webkit.org 2009-07-23 16:02:03 PDT
Fixed in <http://trac.webkit.org/projects/webkit/changeset/46295>.
Comment 4 Simon Fraser (smfr) 2010-02-10 18:18:34 PST
*** Bug 24842 has been marked as a duplicate of this bug. ***