Bug 24842 - CSS rendering engine lacks support for box-shadow inset parameter.
Summary: CSS rendering engine lacks support for box-shadow inset parameter.
Status: RESOLVED DUPLICATE of bug 27582
Alias: None
Product: WebKit
Classification: Unclassified
Component: CSS (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh OS X 10.5
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-03-26 07:50 PDT by Jakub Pawłowicz
Modified: 2013-04-20 06:03 PDT (History)
4 users (show)

See Also:


Attachments
Bug HTML test case. (657 bytes, text/html)
2009-03-26 07:53 PDT, Jakub Pawłowicz
no flags Details
Screenshot of Firefox 3.6 alpha reference rendering. (78.57 KB, image/png)
2009-03-26 07:55 PDT, Jakub Pawłowicz
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jakub Pawłowicz 2009-03-26 07:50:59 PDT
First alpha builds of Firefox 3.6 shows Gecko support for 'inset' parameter in box-shadow CSS declaration.

Discussion on Mozilla's Bugzilla: https://bugzilla.mozilla.org/show_bug.cgi?id=476738
Mozilla MDC page: https://developer.mozilla.org/en/CSS/-moz-box-shadow
Comment 1 Jakub Pawłowicz 2009-03-26 07:53:39 PDT
Created attachment 28967 [details]
Bug HTML test case.

HTML testcase that could be tested against first Firefox 3.6 alpha builds.
Comment 2 Jakub Pawłowicz 2009-03-26 07:55:20 PDT
Created attachment 28969 [details]
Screenshot of Firefox 3.6 alpha reference rendering.
Comment 3 Jakub Pawłowicz 2009-03-27 03:27:35 PDT
The working draft of CSS3-background says this about box-shadow inset property:
"The ‘inset’ keyword, if present, changes the drop shadow from an outer shadow (one that shadows the box onto the canvas, as if it were lifted above the canvas) to an inner shadow (one that shadows the canvas onto the box, as if the box were cut out of the canvas and shifted behind it)"

http://www.w3.org/TR/css3-background/#the-box-shadow
Comment 4 Simon Fraser (smfr) 2010-02-10 18:18:34 PST

*** This bug has been marked as a duplicate of bug 27582 ***