bugzilla-tool or pre-commit hook should validate reviewer lines before committing This will avoid bad commit lines like: http://trac.webkit.org/changeset/45463 We already have a list of authorized reviewers in svn (bugzilla.py for now, but eventually in reviewers.py) so validating a parsed out reviewer name against it is easy.
If I land a patch through the commit-queue that has been reviewed, it could fail if the ChangeLog says "Reviewed by NOBODY". "Reviewed by NOBODY" is a valid line, but probably not the intention if the patch was actually reviewed. Personally I always write "Unreviewed" and then some kind of explanation, like "Unreviewed Qt buildbot fix".
Another bad commit: http://trac.webkit.org/changeset/56454
Created attachment 51572 [details] Patch
Comment on attachment 51572 [details] Patch You are a better man than I. However, this is sub-optimal (and will break the case of the ChangeLog posted already having a valid reviewer). Better would be to look at reviewer() on all the ChangeLogEntries right before we assemble the commit message. We could even validate that that reviewer() matches the one we pulled off the bug, if the bug had one.
Created attachment 51585 [details] Patch
Created attachment 51586 [details] Patch
Comment on attachment 51586 [details] Patch + os.chdir(self._tool.scm().checkout_root) That needs a FIXME. Can we say regexp? + if changelog_entry.contents().lower().find("unreviewed"): re.match("unreviewed", changelog_entry.contents(), re.IGNORECASE) You could/should even just compile the regexp as a class variable on ValidateReviewer. + error('%s neither lists a valid reviewer nor contains the string "Unreviewed".') should note that the search is case insensitive. I am saddened by the lack of the testzors. Otherwise this looks great!
Created attachment 51588 [details] Patch
Comment on attachment 51588 [details] Patch I really dislike the lack of testing. If you get this wrong, then "webkit-patch land" will be broken for people. :( r+, assuming that you've tested this somehow or will...
Committed r56478: <http://trac.webkit.org/changeset/56478>