Bug 268643 - [iOS 17.4 Beta in EU] REGRESSION: PWA added to Home Screen are forced to open in Safari
Summary: [iOS 17.4 Beta in EU] REGRESSION: PWA added to Home Screen are forced to open...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: Safari 17
Hardware: iPhone / iPad iOS 17
: P2 Normal
Assignee: Nobody
URL:
Keywords: InRadar
: 269690 (view as bug list)
Depends on:
Blocks:
 
Reported: 2024-02-02 11:06 PST by Tixie
Modified: 2024-03-11 22:21 PDT (History)
63 users (show)

See Also:


Attachments
Process of adding Squoosh.app to Home Screen and open it on iOS 17.4 beta (iPhone SE 2nd gen) (4.89 MB, video/mp4)
2024-02-02 11:06 PST, Tixie
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Tixie 2024-02-02 11:06:21 PST
Created attachment 469678 [details]
Process of adding Squoosh.app to Home Screen and open it on iOS 17.4 beta (iPhone SE 2nd gen)

Hi,
Since my update to iOS 17.4 (on my iPhone SE 2nd gen) PWA doesn't seems to work as they used to:

I tried to add to my iOS Home Screen different web apps with a web manifest (PWAs) with the "display" value to "standalone" and no matter:
- the display value in the manifest
- if my phone is online or offline
- if I've open the app before

The result is the same:
- It never launch in standalone mode
- Launch Safari and open the web app in a new tab

I've added "REGRESSION" because it seems the PWAs added to Home Screen seems to work as expected until I upgraded iOS to 17.4 (beta channel) 

List of web app that I used regularly in standalone until now and worked: 
- https://squoosh.app (popularly shown as a PWA example working in standalone and offline mode)
- https://twitter.com
- https://souvenir.cam

I've attached a screen capture of the process of adding Squoosh.app to Home Screen and open it.

Also the Squoosh and Souvenir sources are available on Github, hope it can helps.
- https://github.com/GoogleChromeLabs/squoosh
- https://github.com/GuerillaHQ/souvenir

Respectfully,
Tixie
Comment 1 Tixie 2024-02-06 11:26:29 PST
Additional information: Since it seems to be a specific version of the beta for the EU, I'm indeed located in the EU and have this version installed.

A wild guess would be that linked to the new ability for users to choose their default web browser. So indeed that would question on which browser the web app previously added to the Home Screen would run if the default web browser is changed.
However I've personally choose to keep using Safari so it shouldn't have impacted them this much. 
And even prevent new PWAs to be added to the Home Screen with the expected result.
Comment 2 Thomas Steiner 2024-02-07 01:08:49 PST
This behavior is still present in iOS 17.4 (21E5195e). Open “Example app” in Safari. “Example app” will open in your default browser from now on. I use Safari as my default browser and my iPhone has a German SIM. I'm physically in the EU right now.
Comment 3 Peter 2024-02-08 01:43:16 PST
Can confirm PWAs stopped working in EU. This means no web push for our users.
Comment 4 patrik 2024-02-08 02:02:49 PST
Same here, all of my PWAs stopped working properly. Both 17.4 and 17.4 Beta 2 are affected
Comment 5 siim 2024-02-08 06:53:37 PST
No wonder, they haven't even tried to fix previous PWA bugs.
Comment 6 Marek 2024-02-09 00:53:05 PST
The same happened to us, this definitely needs to be fixed.
Comment 7 Radar WebKit Bug Importer 2024-02-09 11:07:16 PST
<rdar://problem/122655738>
Comment 8 Jonathan 2024-02-09 11:10:58 PST
Could someone clarify why this is happening? This regression would have seriously negative impact on 15k+ users who have our pwas installed to their home screens on iPhone and iPad.
Comment 9 Fabien R 2024-02-09 13:58:14 PST
As usual, it's a shame. You're pissing off thousands of developers and companies.
Comment 10 Jesper Bendtsen 2024-02-10 00:35:34 PST
Please say something or get someone in Apple to do it, will service workers be disabled in EU (I append access tokens in the service worker for access to files in blob containers. So it works for both http requests and img src)? Will all my users lose their local storage? Lost their web push subscriptions? And will the PWA not open up in the top level window anymore?

My users will stay in the Safari browser if the PWA works as it does in iOS 17.3.1, they don't want to switch browsers (They know nothing about browsers). If the PWA is not shown in the top level window, they will go for the browser with the smallest address bar and placed at the top, so they don't hit it when they press the add/save fab button bottom right.

But in the end I think it will kill my business, 3 years of hard work! Ruining everything for me without saying anything is evil!
Comment 11 Arno ten Hagen 2024-02-13 13:59:29 PST
Come on apple!! Fix our PWA's please in ios 17.4 beta 4. A lot of people in de EU use PWA's with push notifications in a standalone mode on iOS. You can't make it to give all those users a huge problem.
Comment 12 ouksal 2024-02-13 14:12:34 PST
Apple, please fix PWA.
Comment 13 Gleb Khmyznikov 2024-02-13 15:26:35 PST
Don't be evil.
Comment 14 Alex Suzuki 2024-02-13 22:55:29 PST
Many businesses use PWA for in-house apps, and there were encouraging signs lately with support for Web Push. We have customers asking us what is going on. Please communicate clearly – not even mentioning this issue in the Release Notes is just inconceivable.
Comment 15 aaronlmendoza 2024-02-14 02:15:20 PST
It appears that rectifying this issue may be straightforward upon the reactivation of the code. Has there been a meticulous dissection of the code, followed by a comprehensive comparative analysis? If indeed there exists unequivocal evidence of malevolent intent, the initial course of action should involve the public disclosure of the alterations, elucidating the methodology and rationale behind the modifications. Subsequently, we are compelled to approach the administration of this matter from an entirely novel perspective. Such an approach will underscore that Apple's exertion of influence over its end users transcends mere monopolistic practices, thereby necessitating a multifaceted response.
Comment 16 t0ppy 2024-02-14 02:29:52 PST
On feb 13 this was briefly working on beta 2, before beta 3 was released. After upgrading to beta 3 it's back to the broken behaviour of opening links in the normal browser / not full screen. 

This leads us to believe that we are dealing with a very intentional limitation. 

We have many customers who will be affect by this change. Please clarify the situation.
Comment 17 Judah Gabriel Himango 2024-02-14 16:28:30 PST
This is impacting my app as well.
Comment 18 Pieter 2024-02-15 00:06:57 PST
'Come on apple!! Fix our PWA's please in ios 17.4 beta 4. A lot of people in de EU use PWA's with push notifications in a standalone mode on iOS. You can't make it to give all those users a huge problem.'

Totally agree with Arno - this is an important issue here in the EU
Comment 19 Arjan Vijn 2024-02-15 00:11:06 PST
We need the PWA as app and not to open in the browser. All our customers (2000+) use this as standalone. Please fix this.
Comment 20 Frank Zwiers 2024-02-15 00:14:30 PST
Makes PWA's virtually useless. Quite bad for the user experience of our apps. This will sadden a lot of healthcare providers.
Comment 21 Harm 2024-02-15 00:17:01 PST
This impacts 2000+ of our users who use the PWA as an app. This should be fixed asap
Comment 22 Jules 2024-02-15 00:23:11 PST
This needs to be fixed!

This issue is significantly impacting our user experience and hindering our ability to deliver seamless services to our customers.

It seems the PWAs added to Home Screen work as expected until IOS is upgraded to 17.4.

PWAs don't launch in standalone mode anymore.
Web app is opened in browser in a n new tab.

This is impacting 50K+ of our app users.
Comment 23 Daan Seegers 2024-02-15 00:37:05 PST
Please fix the PWA asap. We need this.
Comment 24 George 2024-02-15 00:42:47 PST
This exist and is problematic. I am not sure if it is only EU, but I am located in eu and experienced this with a couple of web apps.
Comment 25 Wessel 2024-02-15 00:44:54 PST
Our users in the EU are dependent on PWA functioning how it used to. Please fix this, Apple.
Comment 26 Jonathan 2024-02-15 03:02:57 PST
Since there has been zero communication from Apple, we will make it extremely clear to our EU-based iOS app users precisely who is responsible for this setback. We will leverage the recent attention our web app gained from its feature on apple.com to shed light on Apple's blatantly anti-competitive actions. Users will understand how Apple's restrictive practices not only degrade their experience but also inflate costs and hinder disruptive apps like ours, which benefit from the efficiency and cost-effectiveness of a unified code base across platforms.

Now, more than ever, is the time to campaign for the open web and double down on developing premier, web-first applications — applications that will intentionally not function on iOS. We're shifting our approach from appealing to legislators about Apple's monopolistic behaviors to directly educating end users about the disadvantages they face due to these practices. We were motivated before but now it's on!
Comment 27 aweb33 2024-02-15 07:54:25 PST
I spent many hours making my 2 webapps work neatly as PWA. I hope this change will be reverted, because it ruins the UX.

Apple knows UX is central, so please revert this change! Thanks!
Comment 28 Ibe 2024-02-15 12:18:30 PST
Please fix this asap. Many of our customers in healthcare depend on PWA's to provide good care in the Netherlands.
Comment 29 siim 2024-02-15 12:54:55 PST
Apple just confirmed that they killed Home Screen Apps in iOS.

https://developer.apple.com/support/dma-and-apps-in-the-eu#dev-qa
Comment 30 Arno ten Hagen 2024-02-15 13:11:58 PST
I checked https://developer.apple.com/support/dma-and-apps-in-the-eu#dev-qa


"EU users will be able to continue accessing websites directly from their Home Screen through a bookmark with minimal impact to their functionality."

Minimal impact?? OMG

"We expect this change to affect a small number of users."

Small number of users?? You don't have any idea. Only our company/pwa has 250.000 users.
Comment 31 alessandro 2024-02-15 18:12:39 PST
Apple, please don’t break the web.

You’re killing, among others:
- web push
- badges
- full screen apps
- offline capabilities
- web app storage (data will be deleted after 7 days of not visiting a website)
- services like xbox cloud gaming
- wiping everybody’s web app data on existing web apps
- the ability for developers to program an app once and distribute everywhere

You knew about DMA for 2 years, that’s a reasonable amount of time to build OS level support for alternative browser engines, rather than removing support for PWAs.

These sort of actions are specifically called out in the DMA legislation as unacceptable, per article 13(6):

“The gatekeeper shall not degrade the conditions or quality of any of the core platform services provided to business users or end users who avail themselves of the rights or choices laid down in Articles 5, 6 and 7”.

Please, don’t degrade iOS. We all win with an open web.
Comment 32 Manuel Correia 2024-02-15 19:47:13 PST
Same identified,

Built an large user ecosystem with this, counted on Safari to keep the support, suddently, rug-pulled.

Wont be extending any future development to support iOS either.

This is exactly how IE became a joke.
Comment 33 John 2024-02-16 00:10:37 PST
Go to hell, Apple.
Comment 34 Karl Horky 2024-02-16 01:23:07 PST
This deliberate decision to kill PWAs in the EU is hostile to users and businesses which rely on your platform, Apple.

The justification that PWAs are not widespread is not based in reality - I have heard countless accounts of PWA usage.

It is also anticompetitive behavior, and provides a reason to apply additional regulation.

Please reconsider, for the sake of users, businesses and developers (also, students).
Comment 35 Joel 2024-02-16 01:25:43 PST
Feeling defeated here.

We are maintaining an internal web app which relies on multiple PWA functionalities.

Now we are probably going to have to resort to blocking our users from upgrading to 17.4 and start migrating off iOS before that becomes a serious blocker in itself.
Comment 36 Jesper Bendtsen 2024-02-16 02:26:29 PST
This is so stupid. Apple has improved their browser in the last 2 years, implemented support for web push notifications, badge, removed annoying limit of 1 GB local storage for PWA, support for copying cookies when saving a website to the Home Screen, fixed a lot of bugs, etc. But all that for nothing!!!

Apple should make an agreement with DMA that PWA can still run as it does at the moment in Safari. Where in the meantime they have to work on a new integration architecture so that it will be equal for all browsers. There are millions of PWA users right now in the EU who use Safari, and they will continue to do so, if it works as it does in iOS 17.3.1, Apple now has the chance to get their users to stay in Safari. If the PWA opens up as a browser shortcut, users will 100% switch to Google Chrome. If Apple just invested in their own browser, people wouldn't switch browser, I don't think it's money they're missing... Apple is killing companies that have invested in PWA! Apple is killing jobs that exist because of PWA! And in the end Apple is killing its own browser!!! But Apple doesn't seem to care!

Apple could fight like real warriors and make their browser as good as Google Chrome or better, but instead Apple are some bad losers who now just want to make it bad for everyone. It's sad because there are some good webkit people who have a passion for the web and want the best for it...
Comment 37 Tony 2024-02-16 02:51:20 PST
This is really sad. I was so hopeful for PWAs on iOS in the past 2 (or so) years and now all of it will go to waste...

For me as a single dev PWA is an amazing option to run my app on all platforms without the burden of maintaining several codebases etc. I just can't believe this is the solution they came up with...
Comment 38 Jesper Bendtsen 2024-02-16 02:59:37 PST
Apple has no passion for PWA:
https://bugs.webkit.org/show_bug.cgi?id=254395
Comment 39 fisiodes 2024-02-18 13:36:03 PST
Please restore PWA functionality, you are adding a great burden to developers building cross-platform apps
Comment 40 Alexey Proskuryakov 2024-02-19 15:05:38 PST
*** Bug 269690 has been marked as a duplicate of this bug. ***
Comment 41 Jos 2024-02-21 01:22:20 PST
Please fix this Apple!
Comment 42 Jan Kretschmer 2024-02-21 05:57:48 PST
Unlikely they will fix this.. Why sould they?
They don't make money with PWAs or any other good integration of web apps.
Sad reality is they will get away with this. Because they can. Simple as that.
Comment 43 fisiodes 2024-02-21 06:35:20 PST
Please file a complaint about Apple behavior to eu commission: https://competition-policy.ec.europa.eu/antitrust-and-cartels/procedures/complaints_en
Comment 44 Jesper Bendtsen 2024-02-21 23:21:38 PST
Apple Is Trying to Kill the Open Internet!
https://www.youtube.com/watch?v=up-zUEFNMww
Comment 45 Wes Bos 2024-03-01 08:28:37 PST
good news - looks like Apple is reversing this decision https://9to5mac.com/2024/03/01/apple-home-screen-web-apps-ios-17-eu/
Comment 46 Jesper Bendtsen 2024-03-01 08:31:17 PST
It brings me tears of joy, I'm just so relieved. This is a good day in web history :)
Comment 47 Jesper van den Ende 2024-03-01 08:46:59 PST
Does this mean other browser engines can install apps to the home screen as well?
Comment 48 Jan Kretschmer 2024-03-01 08:51:29 PST
It says in the statement it’s supposed to work again with iOS 17.4. I have 17.4. It’s not working.
Can someone confirm homescreen web apps work (at least without address bar) for them on iOS 17.4.?
Comment 49 Alex Suzuki 2024-03-04 02:16:54 PST
@Jesper van den Ende: No, PWAs will run on WebKit for the time being. There is no word whether they plan to expose the capability to install apps to the Home Screen to other browser engines.
Comment 50 Tixie 2024-03-11 22:19:39 PDT
Hello everyone,
After a hell of a roller-coster I can confirm that since the stable iOS 17.4 have been release on March 5 (and considering the small statement Apple made half hidden behind an accordion on https://developer.apple.com/support/dma-and-apps-in-the-eu/) progressive web app added to Home Screen are back to their original behavior, aka:
- openable in full screen
- local data persistency (longer than the 7days applied to in-browser apps)
- web push notifications & icon badge (and their system level integration in notifications settings like any native app)
- And I may have forgot some, feel free to complete

Additional note: for those who tested the beta EU version, the preexisting added to home apps not “converted into bookmarks” (so, not launched during that time), can be launched again since the stable 17.4 release without fear of losing the locally stored data or cookies.

Indeed, there are still a lot to do to allow PWAs to have a great experience and integration closer to what native apps have (thinking about thinks like in-browser install prompts like native apps, or web share target). But that’s a different and broader subject(s) out of scope of this ticket.

But for the issue described in the ticket: *I consider it resolved*. Things are back like they used to be before iOS 17.4 beta.

So to conclude a bit: despite that bitter taste of being gaslighted left by how Apple’s legal department handled this case with silence until the last moment and very few declarations, I would like *to sincerely thanks* the people who took the decision to rollback the breaking change. Thank you!

I’m also sending all my kind regards to all the folks from Apple web department who had to face panty of angry developers and business owners who online impacted by that regressive decision despite the more than probable fact that they weren’t involved at all in this poor decision, considering all the recent work they’ve done to make the web experience better on the Apple ecosystem the past few years. 🫶 to you!