Bug 26610 - WebKit does not properly disable underline for selected text when underline is defined with U tags
Summary: WebKit does not properly disable underline for selected text when underline i...
Status: RESOLVED DUPLICATE of bug 20215
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: 523.x (Safari 3)
Hardware: PC OS X 10.5
: P3 Minor
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-06-22 10:46 PDT by Venkat Karun
Modified: 2009-06-22 10:54 PDT (History)
1 user (show)

See Also:


Attachments
The HTML file containing the reduction (521 bytes, text/html)
2009-06-22 10:47 PDT, Venkat Karun
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Venkat Karun 2009-06-22 10:46:16 PDT
This manifests with all versions of Webkit. You can use the following steps to
reproduce this.

a) Open the attached HTML page.
b) Select any portion of the underlined text and click on the underline button.
c) The underline still persists.

Notes: The U tag (<u style="">) enclosing the SPAN negates the inline-style applied to the SPAN after the operation.
Comment 1 Venkat Karun 2009-06-22 10:47:12 PDT
Created attachment 31654 [details]
The HTML file containing the reduction
Comment 2 Julie Parent 2009-06-22 10:54:36 PDT

*** This bug has been marked as a duplicate of 20215 ***