Bug 26301 - Test bug for bugzilla scripts -- see bug 26283
Summary: Test bug for bugzilla scripts -- see bug 26283
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Tools / Tests (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh OS X 10.5
: P5 Normal
Assignee: Eric Seidel (no email)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-06-10 15:53 PDT by Eric Seidel (no email)
Modified: 2011-05-17 10:49 PDT (History)
0 users

See Also:


Attachments
test file - please ignore review flag (5 bytes, text/plain)
2009-06-15 15:23 PDT, Eric Seidel (no email)
no flags Details
another test (please ignore review on this test) (5 bytes, text/plain)
2009-06-15 16:41 PDT, Eric Seidel (no email)
no flags Details
Foobar (2.26 KB, patch)
2009-06-17 15:33 PDT, Eric Seidel (no email)
no flags Details | Formatted Diff | Diff
This matches the default up in WebKit (that was changed in r43318). (2.26 KB, patch)
2009-06-17 15:34 PDT, Eric Seidel (no email)
no flags Details | Formatted Diff | Diff
Make Settings::shouldPaintNativeControls default to true (2.26 KB, patch)
2009-06-17 15:56 PDT, Eric Seidel (no email)
no flags Details | Formatted Diff | Diff
Make Settings::shouldPaintNativeControls default to true (2.26 KB, patch)
2009-06-17 15:58 PDT, Eric Seidel (no email)
no flags Details | Formatted Diff | Diff
foo (83 bytes, patch)
2009-06-17 16:57 PDT, Eric Seidel (no email)
no flags Details | Formatted Diff | Diff
Make Settings::shouldPaintNativeControls default to true (2.26 KB, patch)
2009-06-17 17:28 PDT, Eric Seidel (no email)
no flags Details | Formatted Diff | Diff
Update layout test results for addition of datagrid element. (937 bytes, patch)
2009-06-17 17:28 PDT, Eric Seidel (no email)
no flags Details | Formatted Diff | Diff
2009-06-17 David Levin <levin@chromium.org> (1.25 KB, patch)
2009-06-17 17:28 PDT, Eric Seidel (no email)
no flags Details | Formatted Diff | Diff
2009-06-17 Eric Carlson <eric.carlson@apple.com> (1.60 KB, patch)
2009-06-17 17:28 PDT, Eric Seidel (no email)
no flags Details | Formatted Diff | Diff
2009-06-17 Sam Weinig <sam@webkit.org> (1.31 KB, patch)
2009-06-17 17:28 PDT, Eric Seidel (no email)
no flags Details | Formatted Diff | Diff
Make Settings::shouldPaintNativeControls default to true (2.26 KB, patch)
2009-06-17 18:03 PDT, Eric Seidel (no email)
no flags Details | Formatted Diff | Diff
Update layout test results for addition of datagrid element. (937 bytes, patch)
2009-06-17 18:03 PDT, Eric Seidel (no email)
no flags Details | Formatted Diff | Diff
patch (162 bytes, patch)
2009-06-22 14:35 PDT, Eric Seidel (no email)
no flags Details | Formatted Diff | Diff
patch (67 bytes, patch)
2009-06-25 14:07 PDT, Eric Seidel (no email)
no flags Details | Formatted Diff | Diff
patch (2.11 KB, patch)
2009-06-25 16:41 PDT, Eric Seidel (no email)
no flags Details | Formatted Diff | Diff
patch (2.11 KB, patch)
2009-06-25 16:42 PDT, Eric Seidel (no email)
eric: commit-queue-
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Eric Seidel (no email) 2009-06-10 15:53:29 PDT
Test bug for bugzilla scripts -- see bug 26299

There will be junk in this bug!
Comment 1 Eric Seidel (no email) 2009-06-10 17:20:17 PDT
Test
Comment 2 Eric Seidel (no email) 2009-06-10 17:21:18 PDT
Test
Comment 3 Eric Seidel (no email) 2009-06-11 15:58:24 PDT
Test
Comment 4 Eric Seidel (no email) 2009-06-11 16:00:11 PDT
Success!
Comment 5 Eric Seidel (no email) 2009-06-11 17:26:13 PDT
Foobar!
Comment 6 Eric Seidel (no email) 2009-06-11 17:26:32 PDT
Yay!  it worked, trying again...
Comment 7 Eric Seidel (no email) 2009-06-15 15:23:19 PDT
Created attachment 31311 [details]
test file - please ignore review flag
Comment 8 Eric Seidel (no email) 2009-06-15 16:27:40 PDT
Comment on attachment 31311 [details]
test file - please ignore review flag

Please ignore the review flag on this attachment, I'm using it for testing my script for the moment.
Comment 9 Eric Seidel (no email) 2009-06-15 16:41:22 PDT
Created attachment 31318 [details]
another test (please ignore review on this test)

Another test for my script.  Please ignore the review flag.
Comment 10 Eric Seidel (no email) 2009-06-17 15:33:54 PDT
Created attachment 31449 [details]
Foobar


---
Comment 11 Eric Seidel (no email) 2009-06-17 15:34:33 PDT
Created attachment 31450 [details]
This matches the default up in WebKit (that was changed in r43318).


---
Comment 12 Eric Seidel (no email) 2009-06-17 15:56:50 PDT
Created attachment 31454 [details]
        Make Settings::shouldPaintNativeControls default to true

        Make Settings::shouldPaintNativeControls default to true

        This matches the default up in WebKit (that was changed in r43318).

        Fixes Bug 26493: REGRESSION (r44758): First tab always uses Mac-style
        form controls
        <https://bugs.webkit.org/show_bug.cgi?id=26493>

        Reviewed by Darin Adler and Dave Hyatt.

        No test possible since DRT always uses Mac-style form controls.

        * page/Settings.cpp: Changed the initial value of
        gShouldPaintNativeControls to true.

        * rendering/RenderThemeSafari.cpp:
        (WebCore::RenderTheme::themeForPage): Added a FIXME about the design
        flaw here involving querying Settings before it's been initialized.

git-svn-id: http://svn.webkit.org/repository/webkit/trunk@44785 268f45cc-cd09-0410-ab3c-d52691b4dbfc
---
 3 files changed, 26 insertions(+), 1 deletions(-)
Comment 13 Eric Seidel (no email) 2009-06-17 15:58:49 PDT
Created attachment 31455 [details]
        Make Settings::shouldPaintNativeControls default to true

        Make Settings::shouldPaintNativeControls default to true

        This matches the default up in WebKit (that was changed in r43318).

        Fixes Bug 26493: REGRESSION (r44758): First tab always uses Mac-style
        form controls
        <https://bugs.webkit.org/show_bug.cgi?id=26493>

        Reviewed by Darin Adler and Dave Hyatt.

        No test possible since DRT always uses Mac-style form controls.

        * page/Settings.cpp: Changed the initial value of
        gShouldPaintNativeControls to true.

        * rendering/RenderThemeSafari.cpp:
        (WebCore::RenderTheme::themeForPage): Added a FIXME about the design
        flaw here involving querying Settings before it's been initialized.

git-svn-id: http://svn.webkit.org/repository/webkit/trunk@44785 268f45cc-cd09-0410-ab3c-d52691b4dbfc
---
 3 files changed, 26 insertions(+), 1 deletions(-)
Comment 14 Eric Seidel (no email) 2009-06-17 16:57:48 PDT
Created attachment 31469 [details]
foo
Comment 15 Eric Seidel (no email) 2009-06-17 17:28:46 PDT
Created attachment 31471 [details]
        Make Settings::shouldPaintNativeControls default to true

        Make Settings::shouldPaintNativeControls default to true

        This matches the default up in WebKit (that was changed in r43318).

        Fixes Bug 26493: REGRESSION (r44758): First tab always uses Mac-style
        form controls
        <https://bugs.webkit.org/show_bug.cgi?id=26493>

        Reviewed by Darin Adler and Dave Hyatt.

        No test possible since DRT always uses Mac-style form controls.

        * page/Settings.cpp: Changed the initial value of
        gShouldPaintNativeControls to true.

        * rendering/RenderThemeSafari.cpp:
        (WebCore::RenderTheme::themeForPage): Added a FIXME about the design
        flaw here involving querying Settings before it's been initialized.

git-svn-id: http://svn.webkit.org/repository/webkit/trunk@44785 268f45cc-cd09-0410-ab3c-d52691b4dbfc
---
 3 files changed, 26 insertions(+), 1 deletions(-)
Comment 16 Eric Seidel (no email) 2009-06-17 17:28:48 PDT
Created attachment 31472 [details]
Update layout test results for addition of datagrid element.

Update layout test results for addition of datagrid element.

git-svn-id: http://svn.webkit.org/repository/webkit/trunk@44784 268f45cc-cd09-0410-ab3c-d52691b4dbfc
---
 1 files changed, 1 insertions(+), 0 deletions(-)
Comment 17 Eric Seidel (no email) 2009-06-17 17:28:49 PDT
Created attachment 31473 [details]
2009-06-17  David Levin  <levin@chromium.org>

2009-06-17  David Levin  <levin@chromium.org>

        Fix chromium Windows build.

        A mistake that happened during the complicated merge for
        landing r44775, r44776, r44777.

        * rendering/RenderThemeChromiumWin.h:
        (WebCore::RenderThemeChromiumWin::RenderThemeChromiumWin):
        (WebCore::RenderThemeChromiumWin::~RenderThemeChromiumWin):

git-svn-id: http://svn.webkit.org/repository/webkit/trunk@44783 268f45cc-cd09-0410-ab3c-d52691b4dbfc
---
 2 files changed, 13 insertions(+), 2 deletions(-)
Comment 18 Eric Seidel (no email) 2009-06-17 17:28:52 PDT
Created attachment 31474 [details]
2009-06-17  Eric Carlson  <eric.carlson@apple.com>

2009-06-17  Eric Carlson  <eric.carlson@apple.com>

        Reviewed by Simon Fraser.

        <rdar://problem/6981193> Crash in MediaControlInputElement::attachToParent

        * rendering/MediaControlElements.cpp:
        (WebCore::MediaTextDisplayElement::attachToParent): NULL check element renderer or parent renderer.
        (WebCore::MediaControlInputElement::attachToParent): Ditto.



git-svn-id: http://svn.webkit.org/repository/webkit/trunk@44782 268f45cc-cd09-0410-ab3c-d52691b4dbfc
---
 2 files changed, 13 insertions(+), 2 deletions(-)
Comment 19 Eric Seidel (no email) 2009-06-17 17:28:53 PDT
Created attachment 31475 [details]
2009-06-17  Sam Weinig  <sam@webkit.org>

2009-06-17  Sam Weinig  <sam@webkit.org>

        Reviewed by Mark Rowe.

        * security/index.html: Fix some typos.



git-svn-id: http://svn.webkit.org/repository/webkit/trunk@44781 268f45cc-cd09-0410-ab3c-d52691b4dbfc
---
 2 files changed, 8 insertions(+), 2 deletions(-)
Comment 20 Eric Seidel (no email) 2009-06-17 18:03:38 PDT
Created attachment 31477 [details]
        Make Settings::shouldPaintNativeControls default to true

        Make Settings::shouldPaintNativeControls default to true

        This matches the default up in WebKit (that was changed in r43318).

        Fixes Bug 26493: REGRESSION (r44758): First tab always uses Mac-style
        form controls
        <https://bugs.webkit.org/show_bug.cgi?id=26493>

        Reviewed by Darin Adler and Dave Hyatt.

        No test possible since DRT always uses Mac-style form controls.

        * page/Settings.cpp: Changed the initial value of
        gShouldPaintNativeControls to true.

        * rendering/RenderThemeSafari.cpp:
        (WebCore::RenderTheme::themeForPage): Added a FIXME about the design
        flaw here involving querying Settings before it's been initialized.

git-svn-id: http://svn.webkit.org/repository/webkit/trunk@44785 268f45cc-cd09-0410-ab3c-d52691b4dbfc
---
 3 files changed, 26 insertions(+), 1 deletions(-)
Comment 21 Eric Seidel (no email) 2009-06-17 18:03:49 PDT
Created attachment 31478 [details]
Update layout test results for addition of datagrid element.

Update layout test results for addition of datagrid element.

git-svn-id: http://svn.webkit.org/repository/webkit/trunk@44784 268f45cc-cd09-0410-ab3c-d52691b4dbfc
---
 1 files changed, 1 insertions(+), 0 deletions(-)
Comment 22 Darin Adler 2009-06-17 18:06:50 PDT
Comment on attachment 31478 [details]
Update layout test results for addition of datagrid element.

Hyatt said he was going to take care of this!
Comment 23 Eric Seidel (no email) 2009-06-22 14:35:53 PDT
Created attachment 31675 [details]
patch
Comment 24 Eric Seidel (no email) 2009-06-25 14:07:21 PDT
Created attachment 31874 [details]
patch
Comment 25 Eric Seidel (no email) 2009-06-25 14:07:47 PDT
Comment on attachment 31874 [details]
patch

Sorry for the review spam.
Comment 26 Eric Seidel (no email) 2009-06-25 16:41:53 PDT
Created attachment 31887 [details]
patch
Comment 27 Eric Seidel (no email) 2009-06-25 16:42:03 PDT
Created attachment 31888 [details]
patch
Comment 28 Eric Seidel (no email) 2009-06-25 18:31:26 PDT
Comment on attachment 31888 [details]
patch

foo
Comment 29 David Kilzer (:ddkilzer) 2009-07-01 13:07:09 PDT
Comment on attachment 31450 [details]
This matches the default up in WebKit (that was changed in r43318).

Changing the description of this attachment since it violates the maximum length of descriptions in future Bugzilla versions.  Here's the previous description:

        This matches the default up in WebKit (that was changed in r43318).        Fixes Bug 26493: REGRESSION (r44758): First tab always uses Mac-style        form controls        <https://bugs.webkit.org/show_bug.cgi?id=26493>        Reviewed by Darin Adler and Dave Hyatt.        No test possible since DRT always uses Mac-style form controls.        * page/Settings.cpp: Changed the initial value of        gShouldPaintNativeControls to true.        * rendering/RenderThemeSafari.cpp:        (WebCore::RenderTheme::themeForPage): Added a FIXME about the design        flaw here involving querying Settings before it's been initialized.git-svn-id: http://svn.webkit.org/repository/webkit/trunk@44785 268f45cc-cd09-0410-ab3c-d52691b4dbfc
Comment 30 Eric Seidel 2009-09-08 13:39:27 PDT
Comment on attachment 31888 [details]
patch

Test setting r+ and cq+ from an account w/o review or commit privileges.
Comment 31 Eric Seidel (no email) 2009-09-08 13:48:30 PDT
Comment on attachment 31888 [details]
patch

Rejecting patch 31888 from review queue.

Eric.C.Seidel@lawrence.edu does not have reviewer permissions according to http://trac.webkit.org/browser/trunk/WebKitTools/Scripts/modules/committers.py.
Comment 32 Eric Seidel (no email) 2009-09-08 14:58:24 PDT
Comment on attachment 31888 [details]
patch

Testing valid reviewer but invalid cq+
Comment 33 Eric Seidel (no email) 2009-09-08 15:02:09 PDT
Comment on attachment 31888 [details]
patch

Rejecting patch 31888 from commit-queue.

Eric.C.Seidel@lawrence.edu does not have committer permissions according to http://trac.webkit.org/browser/trunk/WebKitTools/Scripts/modules/committers.py.
Comment 34 Eric Seidel (no email) 2009-09-08 15:02:59 PDT
Comment on attachment 31888 [details]
patch

removing r+ now that testing is complete.