Bug 26493 - REGRESSION (r44758): First tab always uses Mac-style form controls
: REGRESSION (r44758): First tab always uses Mac-style form controls
Status: RESOLVED FIXED
: WebKit
Layout and Rendering
: 528+ (Nightly build)
: PC Windows XP
: P2 Normal
Assigned To:
:
: InRadar, PlatformOnly, Regression
:
:
  Show dependency treegraph
 
Reported: 2009-06-17 14:35 PST by
Modified: 2009-06-17 15:13 PST (History)


Attachments
patch v1 + ChangeLog (3.38 KB, patch)
2009-06-17 14:45 PST, Adam Roben (:aroben)
darin: review+
Review Patch | Details | Formatted Diff | Diff


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2009-06-17 14:35:20 PST
To reproduce:

1. Launch Safari
2. Go to data:text/html,<button>test
3. Open a new tab
4. Go to data:text/html,<button>test

In step 2, a Mac-style button is drawn. In step 4, a Windows-style button is drawn.

This regressed in r44758 <http://trac.webkit.org/changeset/44758>.
------- Comment #1 From 2009-06-17 14:36:14 PST -------
<rdar://problem/6981976>
------- Comment #2 From 2009-06-17 14:37:47 PST -------
The problem is that RenderTheme::themeForPage is getting called before WebPreferences has communicated its settings to WebCore::Settings. RenderTheme::themeForPage consults Settings to decide whether it should return the RenderThemeWin or RenderThemeSafari instance, but Settings hasn't been initialized yet.
------- Comment #3 From 2009-06-17 14:45:47 PST -------
Created an attachment (id=31441) [details]
patch v1 + ChangeLog
------- Comment #4 From 2009-06-17 14:49:46 PST -------
(From update of attachment 31441 [details])
r=me

I'm sad we have to work around this instead of fixing it. Too bad we didn't realize this was wrong before landing the per-page theme change!
------- Comment #5 From 2009-06-17 14:51:50 PST -------
(From update of attachment 31441 [details])
r=me
------- Comment #6 From 2009-06-17 15:10:27 PST -------
Fixed in r44785
------- Comment #7 From 2009-06-17 15:13:19 PST -------
I've recorded the desire to fix the real bug in bug 26494.