Bug 258439 - AX: Improve accessibility for tables and table components with display flex, grid, block, inline-block, and contents
Summary: AX: Improve accessibility for tables and table components with display flex, ...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Accessibility (show other bugs)
Version: Other
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Tyler Wilcock
URL:
Keywords: InRadar
: 141524 (view as bug list)
Depends on:
Blocks: 239479 257458
  Show dependency treegraph
 
Reported: 2023-06-23 00:00 PDT by Tyler Wilcock
Modified: 2023-06-23 19:39 PDT (History)
11 users (show)

See Also:


Attachments
Patch (43.67 KB, patch)
2023-06-23 00:06 PDT, Tyler Wilcock
no flags Details | Formatted Diff | Diff
Patch (50.74 KB, patch)
2023-06-23 10:55 PDT, Tyler Wilcock
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Tyler Wilcock 2023-06-23 00:00:40 PDT
https://bugs.webkit.org/show_bug.cgi?id=258223 did the hard work of computing table structure based on the DOM rather than the render tree. But even after that patch, tables and table components with assorted display values are often inaccessible to VoiceOver (likely due to parent-child mismatches caused by anonymous table renderers generated when these display values are used).
Comment 1 Radar WebKit Bug Importer 2023-06-23 00:00:53 PDT
<rdar://problem/111202843>
Comment 2 Tyler Wilcock 2023-06-23 00:06:20 PDT
Created attachment 466808 [details]
Patch
Comment 3 chris fleizach 2023-06-23 10:10:03 PDT
Comment on attachment 466808 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=466808&action=review

> Source/WebCore/accessibility/AccessibilityRenderObject.cpp:2255
> +    if (m_renderer->isAnonymous() && (is<RenderTableRow>(m_renderer) || is<RenderTable>(m_renderer)))

should we move this above line 2246, and add the TableCell check there, so all our anonymous check types are together?
Comment 4 Tyler Wilcock 2023-06-23 10:55:47 PDT
Created attachment 466817 [details]
Patch
Comment 5 Tyler Wilcock 2023-06-23 11:32:34 PDT
*** Bug 141524 has been marked as a duplicate of this bug. ***
Comment 6 Tyler Wilcock 2023-06-23 11:36:30 PDT
(In reply to chris fleizach from comment #3)
> Comment on attachment 466808 [details]
> Patch
> 
> View in context:
> https://bugs.webkit.org/attachment.cgi?id=466808&action=review
> 
> > Source/WebCore/accessibility/AccessibilityRenderObject.cpp:2255
> > +    if (m_renderer->isAnonymous() && (is<RenderTableRow>(m_renderer) || is<RenderTable>(m_renderer)))
> 
> should we move this above line 2246, and add the TableCell check there, so
> all our anonymous check types are together?
Fixed!
Comment 7 EWS 2023-06-23 15:40:27 PDT
Committed 265486@main (5da3ca144678): <https://commits.webkit.org/265486@main>

All reviewed patches have been landed. Closing bug and clearing flags on attachment 466817 [details].