Bug 25675 - [Gtk] Formatted text should not result in additional/separate accessibles
Summary: [Gtk] Formatted text should not result in additional/separate accessibles
Status: RESOLVED DUPLICATE of bug 30883
Alias: None
Product: WebKit
Classification: Unclassified
Component: Accessibility (show other bugs)
Version: 528+ (Nightly build)
Hardware: PC Linux
: P2 Normal
Assignee: Nobody
URL:
Keywords: Gtk
Depends on:
Blocks: 25531
  Show dependency treegraph
 
Reported: 2009-05-10 13:38 PDT by Joanmarie Diggs (irc: joanie)
Modified: 2009-12-28 13:05 PST (History)
3 users (show)

See Also:


Attachments
aforementioned test case (98 bytes, text/html)
2009-05-10 13:39 PDT, Joanmarie Diggs (irc: joanie)
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Joanmarie Diggs (irc: joanie) 2009-05-10 13:38:35 PDT
Steps to reproduce:

1. Open the (to be) attached test case.

2. Examine the accessible hierarchy in Accerciser.

Expected results: There would be a single accessible object for the text "This is bold text." (The boldness of the word "bold" would be exposed to ATs as a text attribute. See bug 25528.)

Actual results: There are three accessibles ("This is ", "bold", and " text.")

Xan: Is this representation fundamental to WebKit, or is it a a11y-specific rendering? If the former, let's drop the priority of this bug and I'll see what I can do to work around it in Orca. Otherwise, it would be good for this text to be exposed in a fashion consistent with what we get from other apps. Thanks!
Comment 1 Joanmarie Diggs (irc: joanie) 2009-05-10 13:39:18 PDT
Created attachment 30166 [details]
aforementioned test case
Comment 2 Joanmarie Diggs (irc: joanie) 2009-12-28 13:05:49 PST

*** This bug has been marked as a duplicate of bug 30883 ***