Bug 24312 - Hit test through 3d transforms
Summary: Hit test through 3d transforms
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Layout and Rendering (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh OS X 10.5
: P2 Normal
Assignee: Simon Fraser (smfr)
URL:
Keywords:
: 24573 (view as bug list)
Depends on: 24313 24317
Blocks: 23359
  Show dependency treegraph
 
Reported: 2009-03-02 20:08 PST by Simon Fraser (smfr)
Modified: 2009-03-19 09:22 PDT (History)
6 users (show)

See Also:


Attachments
Patch, changelog. (33.79 KB, patch)
2009-03-02 23:39 PST, Simon Fraser (smfr)
hyatt: review+
Details | Formatted Diff | Diff
Prequel patch: refactor code into transformFromContainer() (7.14 KB, patch)
2009-03-03 09:10 PST, Simon Fraser (smfr)
hyatt: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Simon Fraser (smfr) 2009-03-02 20:08:56 PST
We need to have hit testing be aware of 3d transforms, and preserve-3d style.
Comment 1 Simon Fraser (smfr) 2009-03-02 23:39:57 PST
Created attachment 28214 [details]
Patch, changelog.

Testcases will be added once we turn on support for 3d rendering.
Comment 2 Simon Fraser (smfr) 2009-03-03 09:10:35 PST
Created attachment 28224 [details]
Prequel patch: refactor code into transformFromContainer()
Comment 3 Dave Hyatt 2009-03-03 09:13:25 PST
Comment on attachment 28224 [details]
Prequel patch: refactor code into transformFromContainer()

> diff --git a/WebCore/ChangeLog b/WebCore/ChangeLog
> index e7b3153..0256ec1 100644
> --- a/WebCore/ChangeLog
> +++ b/WebCore/ChangeLog
> @@ -2,6 +2,22 @@
>  
>          Reviewed by NOBODY (OOPS!).
>  
> +        https://bugs.webkit.org/show_bug.cgi?id=24312
> +        
> +        Factor the code that compute a transform relative to the container
> +        into RenderObject::transformFromContainer().
> +      

"that computes a transform"

r=me
Comment 4 Dave Hyatt 2009-03-03 09:19:09 PST
Comment on attachment 28214 [details]
Patch, changelog.

"Recurses through the layer hieraarchy"

Actually just remove this comment.  I think it's just confusing.  hit testing doesn't go through the parent/child hierarchy, which is what the comment implies.
Comment 5 Simon Fraser (smfr) 2009-03-03 09:53:34 PST
Prequel patch:
http://trac.webkit.org/changeset/41387
Comment 6 Simon Fraser (smfr) 2009-03-03 10:11:05 PST
http://trac.webkit.org/changeset/41389
Comment 7 Simon Fraser (smfr) 2009-03-13 08:28:47 PDT
*** Bug 24573 has been marked as a duplicate of this bug. ***
Comment 8 Kari Hiitola 2009-03-19 06:21:15 PDT
I tested with the latest nightly on a Mac, and the hit testing really doesn't seem to work as it should. If you try the test page of the duplicate bug: https://bugs.webkit.org/attachment.cgi?id=28576 the child div can not be clicked. I would suggest reopening this bug. 
Comment 9 Simon Fraser (smfr) 2009-03-19 09:22:54 PDT
Kari: I believe the issue that breaks your is covered by bug 24659.