Bug 23998 - Website crashes Chromium and loads very slowly on WebKit
Summary: Website crashes Chromium and loads very slowly on WebKit
Status: RESOLVED DUPLICATE of bug 23985
Alias: None
Product: WebKit
Classification: Unclassified
Component: Layout and Rendering (show other bugs)
Version: 528+ (Nightly build)
Hardware: PC OS X 10.5
: P2 Normal
Assignee: Nobody
URL: http://www.familyguyx.net/
Keywords:
Depends on:
Blocks:
 
Reported: 2009-02-17 15:41 PST by Jon@Chromium
Modified: 2009-02-17 15:43 PST (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jon@Chromium 2009-02-17 15:41:56 PST
After a recent merge from Webkit this site began to crash the trunk build of Chromium.  In WebKit the site appears to lock up the renderer -- however after perhaps 20 minutes it eventually completes.  The resulting page has an enormous amount of whitespace between the header and a little bit of content at the bottom.

I was unable to get WebKit to produce a stack trace.  Here is what we get from Chromium.

WebCore::InlineFlowBox::addToLine \webcore\rendering\inlineflowbox.cpp@91
WebCore::RenderBlock::constructLine
WebCore::RenderBlock::layoutInlineChildren
WebCore::RenderBlock::layoutBlock
WebCore::RenderBlock::layout

This site loads reasonably in the shipping version of Safari and in Chrome.
Comment 1 Jon@Chromium 2009-02-17 15:43:20 PST

*** This bug has been marked as a duplicate of 23985 ***