Bug 23916 - (r40738) Attempting to expand iframe node with web-inspector causes webkit to crash
Summary: (r40738) Attempting to expand iframe node with web-inspector causes webkit to...
Status: RESOLVED DUPLICATE of bug 23832
Alias: None
Product: WebKit
Classification: Unclassified
Component: Web Inspector (Deprecated) (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh Intel OS X 10.5
: P2 Normal
Assignee: Nobody
URL: http://test.vint.co.nz/iframe-test
Keywords:
Depends on:
Blocks:
 
Reported: 2009-02-12 00:34 PST by Arthur Gunn
Modified: 2009-02-12 01:05 PST (History)
2 users (show)

See Also:


Attachments
crash report for iframe / web-inspector bug (28.90 KB, text/plain)
2009-02-12 01:02 PST, Arthur Gunn
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Arthur Gunn 2009-02-12 00:34:19 PST
Attempting to expand an iframe node, in the elements tab in web-inspector, causes webkit to crash.

Note that the bug does not occur in all cases i.e. here:
http://developer.yahoo.com/yui/examples/editor/toolbar_editor.html

Perhaps because in the yahoo example  the iframe does not use the 'src' attribute?
Comment 1 Arthur Gunn 2009-02-12 00:44:25 PST
Have looked a it further, the crash occurs even without the src attribute.
Perhaps the yahoo example is immune, because the iframe was generated somehow? There is no reference to it in the html I can see.

A further reduction:

<html>
<head>
<title>untitled</title>
</head>
<body>
      <iframe/>
</body>
</html>
Comment 2 Arthur Gunn 2009-02-12 01:02:44 PST
Created attachment 27589 [details]
crash report for iframe / web-inspector bug
Comment 3 Mark Rowe (bdash) 2009-02-12 01:05:28 PST
This was fixed a day or two ago.

*** This bug has been marked as a duplicate of 23832 ***