Bug 23832 - WebKit.app crashes when inspecting image
Summary: WebKit.app crashes when inspecting image
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh OS X 10.5
: P2 Normal
Assignee: Dave Hyatt
URL: http://www.apple.com
Keywords:
: 23916 (view as bug list)
Depends on:
Blocks:
 
Reported: 2009-02-08 09:42 PST by Morten Norby Larsen
Modified: 2009-02-12 01:05 PST (History)
1 user (show)

See Also:


Attachments
Crash log (33.46 KB, text/plain)
2009-02-08 09:43 PST, Morten Norby Larsen
no flags Details
Fix for crash (1.09 KB, patch)
2009-02-08 21:56 PST, Dave Hyatt
no flags Details | Formatted Diff | Diff
Simpler patch (953 bytes, patch)
2009-02-08 22:00 PST, Dave Hyatt
mrowe: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Morten Norby Larsen 2009-02-08 09:42:08 PST
WebKit.app crashes when inspecting image

To reproduce:

1) Go to apple.com
2) Right click on the main picture
3) Select Inspect Element

Result: Crash
Comment 1 Morten Norby Larsen 2009-02-08 09:43:24 PST
Created attachment 27465 [details]
Crash log
Comment 2 Dave Hyatt 2009-02-08 21:56:43 PST
Created attachment 27473 [details]
Fix for crash
Comment 3 Dave Hyatt 2009-02-08 22:00:43 PST
Created attachment 27474 [details]
Simpler patch
Comment 4 Mark Rowe (bdash) 2009-02-08 22:01:29 PST
Comment on attachment 27474 [details]
Simpler patch

r=me
Comment 5 Dave Hyatt 2009-02-08 22:03:37 PST
Fixed in r40777.
Comment 6 Mark Rowe (bdash) 2009-02-12 01:05:28 PST
*** Bug 23916 has been marked as a duplicate of this bug. ***