Bug 23819 - REGRESSION (r36869): Select scroller is shorter than it should be
Summary: REGRESSION (r36869): Select scroller is shorter than it should be
Status: RESOLVED DUPLICATE of bug 34049
Alias: None
Product: WebKit
Classification: Unclassified
Component: Forms (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh OS X 10.5
: P1 Normal
Assignee: Cameron Zwarich (cpst)
URL:
Keywords: InRadar, Regression
Depends on:
Blocks:
 
Reported: 2009-02-07 08:06 PST by John Moe
Modified: 2011-03-28 15:23 PDT (History)
5 users (show)

See Also:


Attachments
Demo (542 bytes, text/html)
2009-02-07 08:06 PST, John Moe
no flags Details
Proposed patch (1.48 KB, patch)
2009-04-22 21:18 PDT, Cameron Zwarich (cpst)
eric: review-
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description John Moe 2009-02-07 08:06:13 PST
Steps:
1. Try to drag thumb to the half way point.  
2. Notice it is not actually at the half way point.
Comment 1 John Moe 2009-02-07 08:06:48 PST
Created attachment 27447 [details]
Demo
Comment 2 Alexey Proskuryakov 2009-02-08 02:11:53 PST
Confirmed as a regression with r40771. The scroller is shorter than it should be, so it appears to be mispositioned when dragging.
Comment 3 Alexey Proskuryakov 2009-02-08 02:13:01 PST
<rdar://problem/6566875>
Comment 4 Adele Peterson 2009-02-10 14:53:17 PST
Adding Hyatt since he wrote http://trac.webkit.org/changeset/40771.
Comment 5 Adele Peterson 2009-02-11 13:21:05 PST
Oh, Alexey clarified that 40771 is just the revision he used to confirm the bug, not the cause of the bug.
Comment 6 Cameron Zwarich (cpst) 2009-04-22 18:53:02 PDT
This regressed between the r36847 and r36882 nightlies. It shouldn't be too hard to find the exact point of the regression, because it's such a small range.
Comment 7 Cameron Zwarich (cpst) 2009-04-22 19:25:10 PDT
This regressed in r36869:

http://trac.webkit.org/changeset/36869
Comment 8 Cameron Zwarich (cpst) 2009-04-22 21:18:36 PDT
Created attachment 29704 [details]
Proposed patch

Do we usually add pixel tests for something like this?
Comment 9 Darin Adler 2009-04-23 09:07:09 PDT
Comment on attachment 29704 [details]
Proposed patch

r=me

And, yes, a manual test or a pixel test or both would be good to add.
Comment 10 Eric Seidel (no email) 2009-04-29 14:50:50 PDT
Assigning to cpst for test addition and landing.
Comment 11 Eric Seidel (no email) 2009-06-15 18:59:43 PDT
cpst?  Ping?
Comment 12 Eric Seidel (no email) 2009-06-24 01:07:40 PDT
cpst:  ping?  Please advise.
Comment 13 Eric Seidel (no email) 2009-06-24 18:35:33 PDT
Comment on attachment 29704 [details]
Proposed patch

r- for lack of tests per darin's comment above.  Can't land this.
Comment 14 Simon Fraser (smfr) 2011-03-28 15:23:40 PDT

*** This bug has been marked as a duplicate of bug 34049 ***