Bug 23773 - SVG animateTransform is sometimes not applied
Summary: SVG animateTransform is sometimes not applied
Status: RESOLVED WORKSFORME
Alias: None
Product: WebKit
Classification: Unclassified
Component: SVG (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh OS X 10.5
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks: 41761
  Show dependency treegraph
 
Reported: 2009-02-05 15:36 PST by Chris Marrin
Modified: 2011-09-04 05:26 PDT (History)
5 users (show)

See Also:


Attachments
Yes, I can confirm it looks fixed on recent beta version... (2.07 KB, image/svg+xml)
2011-07-04 07:28 PDT, marek
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Chris Marrin 2009-02-05 15:36:17 PST
run LayoutTests/svg/W3C-SVG-1.1/animate-elem-30-t.svg. The animated circle may or may not follow the path. Reload over and over and notice that sometimes it does and sometimes it doesn't. It looks like sometimes it is applying the <animateTransform> and sometimes it is not.
Comment 1 marek 2010-09-07 14:48:45 PDT
I have similar experience. When running from script beginElement() on the same element for animateTransform more than once, it stops working. On common animate it works properly, but animateTransform is somewhat broken...
Comment 2 Dirk Schulze 2011-07-04 01:50:45 PDT
I have not seen this bug before. I reloaded the test about 20 times and the animation began on all elements, always. Maybe this was fixed?
Comment 3 marek 2011-07-04 07:28:41 PDT
Created attachment 99628 [details]
Yes, I can confirm it looks fixed on recent beta version...