Bug 237126 - [MacCatalyst] REGRESSION(r290091): sometimes can crash if `WKWebView` is deallocated before the next visible content rect update
Summary: [MacCatalyst] REGRESSION(r290091): sometimes can crash if `WKWebView` is deal...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Devin Rousso
URL:
Keywords: InRadar
: 237145 (view as bug list)
Depends on: 236745
Blocks:
  Show dependency treegraph
 
Reported: 2022-02-23 19:04 PST by Devin Rousso
Modified: 2022-02-24 10:41 PST (History)
7 users (show)

See Also:


Attachments
Patch (10.04 KB, patch)
2022-02-23 19:06 PST, Devin Rousso
no flags Details | Formatted Diff | Diff
[fast-cq] Patch (9.82 KB, patch)
2022-02-24 08:55 PST, Devin Rousso
ews-feeder: commit-queue-
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Devin Rousso 2022-02-23 19:04:06 PST
.
Comment 1 Devin Rousso 2022-02-23 19:05:05 PST
<rdar://problem/89345853>
Comment 2 Devin Rousso 2022-02-23 19:06:22 PST
Created attachment 453065 [details]
Patch
Comment 3 Tim Horton 2022-02-23 19:08:49 PST
Comment on attachment 453065 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=453065&action=review

> Tools/TestWebKitAPI/Tests/WebKitCocoa/WKWebViewResize.mm:44
> +        if ([exception.name hasPrefix:@"Assertion deallocated before it was invalidated."])

Any exception during dealloc would be bad, not sure why you’re being so specific (and making the test extremely susceptible to false positives if the string changes)
Comment 4 Devin Rousso 2022-02-23 20:02:22 PST
Comment on attachment 453065 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=453065&action=review

>> Tools/TestWebKitAPI/Tests/WebKitCocoa/WKWebViewResize.mm:44
>> +        if ([exception.name hasPrefix:@"Assertion deallocated before it was invalidated."])
> 
> Any exception during dealloc would be bad, not sure why you’re being so specific (and making the test extremely susceptible to false positives if the string changes)

Good point.  Not really sure why I'm being so specific.  I'll remove the `hasPrefix:` and unconditionally `didThrow = true` instead..
Comment 5 Devin Rousso 2022-02-24 08:55:48 PST
Created attachment 453104 [details]
[fast-cq] Patch
Comment 6 Wenson Hsieh 2022-02-24 10:20:48 PST
*** Bug 237145 has been marked as a duplicate of this bug. ***
Comment 7 EWS 2022-02-24 10:31:11 PST
Committed r290442 (247745@main): <https://commits.webkit.org/247745@main>

All reviewed patches have been landed. Closing bug and clearing flags on attachment 453104 [details].