Bug 235408 - CSP: Implement wasm-unsafe-eval
Summary: CSP: Implement wasm-unsafe-eval
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebCore Misc. (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Patrick Griffis
URL:
Keywords: InRadar
: 197759 (view as bug list)
Depends on: 235319
Blocks:
  Show dependency treegraph
 
Reported: 2022-01-20 09:05 PST by Patrick Griffis
Modified: 2022-03-10 11:12 PST (History)
3 users (show)

See Also:


Attachments
Patch (24.17 KB, patch)
2022-01-20 09:07 PST, Patrick Griffis
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Patrick Griffis 2022-01-20 09:05:37 PST
CSP: Implement wasm-unsafe-eval
Comment 1 Patrick Griffis 2022-01-20 09:07:17 PST
Created attachment 449587 [details]
Patch
Comment 2 Kate Cheney 2022-01-20 12:30:34 PST
Comment on attachment 449587 [details]
Patch

r=me, but looks like you need to rebase your patch.
Comment 3 Patrick Griffis 2022-01-20 13:38:09 PST
It is blocked by bug 235319 - will rebase after that.
Comment 4 Radar WebKit Bug Importer 2022-01-27 09:06:17 PST
<rdar://problem/88136008>
Comment 5 EWS 2022-02-02 18:18:27 PST
Committed r289022 (246730@main): <https://commits.webkit.org/246730@main>

All reviewed patches have been landed. Closing bug and clearing flags on attachment 449587 [details].
Comment 6 Kate Cheney 2022-03-10 11:12:08 PST
*** Bug 197759 has been marked as a duplicate of this bug. ***