Bug 235266 - [LFC][IFC] Enable content with complex font codepath for IFC
Summary: [LFC][IFC] Enable content with complex font codepath for IFC
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Layout and Rendering (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: zalan
URL:
Keywords: InRadar
: 193491 197277 197409 197411 217421 217946 218510 218930 224590 226474 230414 232910 (view as bug list)
Depends on:
Blocks:
 
Reported: 2022-01-15 06:24 PST by zalan
Modified: 2022-01-17 09:53 PST (History)
11 users (show)

See Also:


Attachments
Patch (83.03 KB, patch)
2022-01-15 06:26 PST, zalan
no flags Details | Formatted Diff | Diff
Patch (123.61 KB, patch)
2022-01-15 09:43 PST, zalan
no flags Details | Formatted Diff | Diff
Patch (123.10 KB, patch)
2022-01-15 10:45 PST, zalan
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description zalan 2022-01-15 06:24:47 PST
ssia
Comment 1 zalan 2022-01-15 06:26:16 PST
Created attachment 449252 [details]
Patch
Comment 2 Antti Koivisto 2022-01-15 07:14:26 PST
Comment on attachment 449252 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=449252&action=review

> Source/WebCore/layout/integration/LayoutIntegrationCoverage.cpp:-406
> -            SET_REASON_AND_RETURN_IF_NEEDED(FlowHasComplexFontCodePath, reasons, includeReasons);

Not removing FlowHasComplexFontCodePath?
Comment 3 zalan 2022-01-15 09:43:17 PST
Created attachment 449254 [details]
Patch
Comment 4 zalan 2022-01-15 09:43:38 PST
(In reply to Antti Koivisto from comment #2)
> Comment on attachment 449252 [details]
> Patch
> 
> View in context:
> https://bugs.webkit.org/attachment.cgi?id=449252&action=review
> 
> > Source/WebCore/layout/integration/LayoutIntegrationCoverage.cpp:-406
> > -            SET_REASON_AND_RETURN_IF_NEEDED(FlowHasComplexFontCodePath, reasons, includeReasons);
> 
> Not removing FlowHasComplexFontCodePath?
good point!
Comment 5 zalan 2022-01-15 10:45:13 PST
Created attachment 449258 [details]
Patch
Comment 6 EWS 2022-01-15 20:44:23 PST
Committed r288070 (246090@main): <https://commits.webkit.org/246090@main>

All reviewed patches have been landed. Closing bug and clearing flags on attachment 449258 [details].
Comment 7 Radar WebKit Bug Importer 2022-01-15 20:45:17 PST
<rdar://problem/87645178>
Comment 9 zalan 2022-01-16 20:38:07 PST
(In reply to Wenson Hsieh from comment #8)
> It seems like several `TestWebKitAPI.WKInspectorExtension*` API tests
> started failing or timing out after this change:
> 
> https://results.webkit.org/?suite=api-tests&suite=api-tests&suite=api-
> tests&suite=api-tests&suite=api-tests&suite=api-tests&suite=api-
> tests&suite=api-tests&suite=api-tests&test=TestWebKitAPI.
> WKInspectorExtension.CanEvaluateScriptInExtensionTab&test=TestWebKitAPI.
> WKInspectorExtension.
> EvaluateScriptInExtensionTabCanReturnPromises&test=TestWebKitAPI.
> WKInspectorExtension.EvaluateScriptOnPage&test=TestWebKitAPI.
> WKInspectorExtension.ExtensionTabIsPersistent&test=TestWebKitAPI.
> WKInspectorExtensionDelegate.
> ExtensionTabNavigatedCallbacks&test=TestWebKitAPI.
> WKInspectorExtensionDelegate.
> InspectedPageNavigatedCallbacks&test=TestWebKitAPI.
> WKInspectorExtensionDelegate.ShowAndHideTabCallbacks&test=TestWebKitAPI.
> WKInspectorExtensionHost.RegisterExtension&test=TestWebKitAPI.
> WKInspectorExtensionHost.UnregisterExtension
Odd. Will take a look.
Comment 10 zalan 2022-01-16 20:48:14 PST
The TestWebKitAPI content triggers ASSERT(partialRun->length); in InlineContentBreaker::tryBreakingPreviousNonOverflowingRuns
Interesting. Fixing it...
Comment 11 zalan 2022-01-16 20:52:23 PST
(In reply to zalan from comment #10)
> The TestWebKitAPI content triggers ASSERT(partialRun->length); in
> InlineContentBreaker::tryBreakingPreviousNonOverflowingRuns
> Interesting. Fixing it...
Nope, the inspector content triggers the assert and not the test content.
Comment 12 zalan 2022-01-16 22:01:46 PST
bug 235286
Comment 13 zalan 2022-01-17 09:28:17 PST
(In reply to Wenson Hsieh from comment #8)
> It seems like several `TestWebKitAPI.WKInspectorExtension*` API tests
> started failing or timing out after this change:
> 
> https://results.webkit.org/?suite=api-tests&suite=api-tests&suite=api-
> tests&suite=api-tests&suite=api-tests&suite=api-tests&suite=api-
> tests&suite=api-tests&suite=api-tests&test=TestWebKitAPI.
> WKInspectorExtension.CanEvaluateScriptInExtensionTab&test=TestWebKitAPI.
> WKInspectorExtension.
> EvaluateScriptInExtensionTabCanReturnPromises&test=TestWebKitAPI.
> WKInspectorExtension.EvaluateScriptOnPage&test=TestWebKitAPI.
> WKInspectorExtension.ExtensionTabIsPersistent&test=TestWebKitAPI.
> WKInspectorExtensionDelegate.
> ExtensionTabNavigatedCallbacks&test=TestWebKitAPI.
> WKInspectorExtensionDelegate.
> InspectedPageNavigatedCallbacks&test=TestWebKitAPI.
> WKInspectorExtensionDelegate.ShowAndHideTabCallbacks&test=TestWebKitAPI.
> WKInspectorExtensionHost.RegisterExtension&test=TestWebKitAPI.
> WKInspectorExtensionHost.UnregisterExtension
https://trac.webkit.org/changeset/288095/webkit should take care of these failures. Thanks!
Comment 14 Arcady Goldmints-Orlov 2022-01-17 09:33:30 PST
*** Bug 218510 has been marked as a duplicate of this bug. ***
Comment 15 Arcady Goldmints-Orlov 2022-01-17 09:38:09 PST
*** Bug 218930 has been marked as a duplicate of this bug. ***
Comment 16 Arcady Goldmints-Orlov 2022-01-17 09:38:51 PST
*** Bug 226474 has been marked as a duplicate of this bug. ***
Comment 17 Arcady Goldmints-Orlov 2022-01-17 09:40:53 PST
*** Bug 217421 has been marked as a duplicate of this bug. ***
Comment 18 Arcady Goldmints-Orlov 2022-01-17 09:42:54 PST
*** Bug 217946 has been marked as a duplicate of this bug. ***
Comment 19 Arcady Goldmints-Orlov 2022-01-17 09:43:51 PST
*** Bug 197277 has been marked as a duplicate of this bug. ***
Comment 20 Arcady Goldmints-Orlov 2022-01-17 09:44:47 PST
*** Bug 197409 has been marked as a duplicate of this bug. ***
Comment 21 Arcady Goldmints-Orlov 2022-01-17 09:45:20 PST
*** Bug 197411 has been marked as a duplicate of this bug. ***
Comment 22 Arcady Goldmints-Orlov 2022-01-17 09:51:11 PST
*** Bug 224590 has been marked as a duplicate of this bug. ***
Comment 23 Arcady Goldmints-Orlov 2022-01-17 09:52:09 PST
*** Bug 193491 has been marked as a duplicate of this bug. ***
Comment 24 Arcady Goldmints-Orlov 2022-01-17 09:52:40 PST
*** Bug 230414 has been marked as a duplicate of this bug. ***
Comment 25 Arcady Goldmints-Orlov 2022-01-17 09:53:25 PST
*** Bug 232910 has been marked as a duplicate of this bug. ***