Bug 235063 - Assertion failure when combining transformed body and dialog element
Summary: Assertion failure when combining transformed body and dialog element
Status: RESOLVED DUPLICATE of bug 235194
Alias: None
Product: WebKit
Classification: Unclassified
Component: CSS (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2022-01-11 04:31 PST by Martin Robinson
Modified: 2022-01-19 04:13 PST (History)
4 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Robinson 2022-01-11 04:31:36 PST
fast/layers/top-layer-ancestor-opacity-and-transform-crash.html has the following assertion failure:

ASSERTION FAILED: !currContainer->hasTransform()
./rendering/RenderObject.cpp(1448) : WebCore::LayoutSize WebCore::RenderObject::offsetFromAncestorContainer(WebCore::RenderElement &) const
1   0x150fbc0b9 WTFCrash
2   0x1670b126b WTFCrashWithInfo(int, char const*, char const*, int)
3   0x16c12fbb6 WebCore::RenderObject::offsetFromAncestorContainer(WebCore::RenderElement&) const
4   0x16bf723a2 WebCore::RenderBox::pushMappingToContainer(WebCore::RenderLayerModelObject const*, WebCore::RenderGeometryMap&) const
5   0x16c03c16f WebCore::RenderGeometryMap::pushMappingsToAncestor(WebCore::RenderObject const*, WebCore::RenderLayerModelObject const*)
6   0x16c03c53d WebCore::RenderGeometryMap::pushMappingsToAncestor(WebCore::RenderLayer const*, WebCore::RenderLayer const*, bool)
7   0x16c0687c2 WebCore::RenderLayer::updateLayerPositions(WebCore::RenderGeometryMap*, WTF::OptionSet<WebCore::RenderLayer::UpdateLayerPositionsFlag>)
8   0x16c068fa1 WebCore::RenderLayer::updateLayerPositions(WebCore::RenderGeometryMap*, WTF::OptionSet<WebCore::RenderLayer::UpdateLayerPositionsFlag>)
9   0x16c068fa1 WebCore::RenderLayer::updateLayerPositions(WebCore::RenderGeometryMap*, WTF::OptionSet<WebCore::RenderLayer::UpdateLayerPositionsFlag>)
10  0x16c068fa1 WebCore::RenderLayer::updateLayerPositions(WebCore::RenderGeometryMap*, WTF::OptionSet<WebCore::RenderLayer::UpdateLayerPositionsFlag>)
11  0x16c06925a WebCore::RenderLayer::updateLayerPositionsAfterLayout(bool, bool)
12  0x16b479f91 WebCore::FrameView::didLayout(WTF::WeakPtr<WebCore::RenderElement, WTF::EmptyCounter>)
13  0x16b46f8c8 WebCore::FrameViewLayoutContext::layout()
14  0x16b4830ed WebCore::FrameView::updateContentsSize()
15  0x16b715ca0 WebCore::ScrollView::updateScrollbars(WebCore::IntPoint const&)
16  0x16b71761a WebCore::ScrollView::setContentsSize(WebCore::IntSize const&)
17  0x16b475196 WebCore::FrameView::setContentsSize(WebCore::IntSize const&)
18  0x16b46c5e7 WebCore::FrameView::adjustViewSize()
19  0x16b46f744 WebCore::FrameViewLayoutContext::layout()
20  0x16b4830ed WebCore::FrameView::updateContentsSize()
21  0x16b715ca0 WebCore::ScrollView::updateScrollbars(WebCore::IntPoint const&)
22  0x16b71761a WebCore::ScrollView::setContentsSize(WebCore::IntSize const&)
23  0x16b475196 WebCore::FrameView::setContentsSize(WebCore::IntSize const&)
24  0x16b46c5e7 WebCore::FrameView::adjustViewSize()
25  0x16b46f744 WebCore::FrameViewLayoutContext::layout()
26  0x16a596706 WebCore::Document::implicitClose()
27  0x16b2266fb WebCore::FrameLoader::checkCallImplicitClose()
28  0x16b226131 WebCore::FrameLoader::checkCompleted()
29  0x16b224317 WebCore::FrameLoader::finishedParsing()
30  0x16a5abab1 WebCore::Document::finishedParsing()
31  0x16ad424c8 WebCore::HTMLConstructionSite::finishedParsing()
com.apple.WebKit.WebContent.Development terminated (pid 68296) because the process crashed
Comment 1 Radar WebKit Bug Importer 2022-01-18 04:32:21 PST
<rdar://problem/87706356>
Comment 2 Martin Robinson 2022-01-19 04:13:55 PST

*** This bug has been marked as a duplicate of bug 235194 ***