Bug 233096 - internal error compiling shader with Metal Backend
Summary: internal error compiling shader with Metal Backend
Status: RESOLVED DUPLICATE of bug 231490
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebGL (show other bugs)
Version: Safari 15
Hardware: Mac (Apple Silicon) Other
: P2 Major
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-11-14 00:12 PST by Muk Sir
Modified: 2021-11-18 08:32 PST (History)
4 users (show)

See Also:


Attachments
A screenshot of the error (6.32 MB, image/png)
2021-11-14 00:12 PST, Muk Sir
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Muk Sir 2021-11-14 00:12:42 PST
Created attachment 444171 [details]
A screenshot of the error

I was trying to load Tanki Online - a browser-based game on my MacBook. It wouldn't let me in. It gave me the error of "Exception: Program Link Error: Internal error compiling shader with Metal backend. Please report this shader or website as a bug on https://bugs.webkit.org". Therefore, I came here to submit the bug.

Additional info :

1. Computer = MacBook Air (M1,2020)
2. OS = macOS Monterey 12.0.1
3. Browser Version = Safari 15.1 (17612.2.9.1.20)

Hoping this gets resolved soon.
Comment 1 Kimmo Kinnunen 2021-11-15 00:21:52 PST
Thanks for the report. This has been fixed and will be shipped in one of the upcoming releases.

*** This bug has been marked as a duplicate of bug 231490 ***
Comment 2 Muk Sir 2021-11-18 08:32:25 PST
(In reply to Kimmo Kinnunen from comment #1)
> Thanks for the report. This has been fixed and will be shipped in one of the
> upcoming releases.
> 
> *** This bug has been marked as a duplicate of bug 231490 ***

Thanks for the confirmation. I can see that it has been fixed in the Safari Technology Preview. I'm sorry for submitting a duplicate bug- I didn't know that it was already submitted.