Bug 23264 - css2.1/t1205-c566-list-stl-00-e-ag.html is failing
Summary: css2.1/t1205-c566-list-stl-00-e-ag.html is failing
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Tools / Tests (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh OS X 10.5
: P2 Normal
Assignee: Nobody
URL:
Keywords:
: 31619 (view as bug list)
Depends on:
Blocks:
 
Reported: 2009-01-12 13:01 PST by Pierre-Olivier Latour
Modified: 2009-11-30 23:37 PST (History)
5 users (show)

See Also:


Attachments
Patch v1 (296.15 KB, patch)
2009-11-04 14:36 PST, Shinichiro Hamaji
no flags Details | Formatted Diff | Diff
Patch v2 (285.64 KB, patch)
2009-11-18 08:39 PST, Shinichiro Hamaji
hyatt: review-
Details | Formatted Diff | Diff
Patch v3 (286.05 KB, patch)
2009-11-20 08:07 PST, Shinichiro Hamaji
mitz: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Pierre-Olivier Latour 2009-01-12 13:01:21 PST
css2.1/t1205-c566-list-stl-00-e-ag.html is failing
Comment 1 Shinichiro Hamaji 2009-11-04 14:36:56 PST
Created attachment 42522 [details]
Patch v1
Comment 2 Shinichiro Hamaji 2009-11-04 14:39:11 PST
This patch will fix Bug 23262 as well. The following URL would describe this bug well:

http://tinyurl.com/yf2vux5
Comment 3 mitz 2009-11-16 10:42:13 PST
Comment on attachment 42522 [details]
Patch v1

Shouldn’t there be a matching change to RenderBlock::calcInlinePrefWidths()?
Comment 4 Shinichiro Hamaji 2009-11-18 02:07:25 PST
(In reply to comment #3)
> (From update of attachment 42522 [details])
> Shouldn’t there be a matching change to RenderBlock::calcInlinePrefWidths()?

Ah, true. This bug happens even without list-style-position:inside. I filed Bug 31619 for this issue. Thanks for this very nice catch!
Comment 5 Shinichiro Hamaji 2009-11-18 08:36:18 PST
*** Bug 31619 has been marked as a duplicate of this bug. ***
Comment 6 Shinichiro Hamaji 2009-11-18 08:39:54 PST
Created attachment 43436 [details]
Patch v2

I merged patch with Bug 31619's. It seems Qt version of buildbot was updated (http://trac.webkit.org/changeset/50878) and I think I need to upgrade my Qt version to produce correct expectations. Please let me mark them as skipped for now. I'll fix them later.
Comment 7 mitz 2009-11-19 08:55:21 PST
WebKit’s current behavior matches Firefox and appears to be intentional. Not sure this bug is valid.
Comment 8 Dave Hyatt 2009-11-19 13:44:37 PST
Comment on attachment 43436 [details]
Patch v2

If we do the right thing for outside list markers, then it seems like you should just be able to drop the !inside checks and have the right thing happen rather than adding new code.
Comment 9 Dave Hyatt 2009-11-19 13:44:59 PST
I agree that this is a bug, and that we should fix the behavior.
Comment 10 Shinichiro Hamaji 2009-11-20 08:07:23 PST
Created attachment 43581 [details]
Patch v3

> If we do the right thing for outside list markers, then it seems like you
> should just be able to drop the !inside checks and have the right thing happen
> rather than adding new code.

Ah yes, I was confused. I updated my patch. Could you take a look again?
Comment 11 Shinichiro Hamaji 2009-11-30 14:12:34 PST
David and Dan, could you take another look at the updated patch? I think I addressed all of your comments. Thanks!
Comment 12 Shinichiro Hamaji 2009-11-30 23:37:41 PST
Committed r51527: <http://trac.webkit.org/changeset/51527>