Bug 23219 - Background-position does not Transition
: Background-position does not Transition
Status: RESOLVED FIXED
Product: WebKit
Classification: Unclassified
Component: CSS
: 528+ (Nightly build)
: Macintosh OS X 10.5
: P2 Normal
Assigned To: Simon Fraser (smfr)
http://farukat.es/bugs/webkit-backgro...
: NeedsRadar
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-09 16:28 PST by Faruk Ates
Modified: 2009-04-24 09:11 PDT (History)
2 users (show)

See Also:


Attachments
Patch, changelog, testcases (12.79 KB, patch)
2009-04-23 22:55 PDT, Simon Fraser (smfr)
darin: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Faruk Ates 2009-01-09 16:28:22 PST
Specifying a CSS Transition on background-position has no effect. See URL for testcase example of a background image moving from 40px 40px to 80px 80px on :hover but there's no transition being applied at all.
Comment 1 Faruk Ates 2009-02-26 15:03:36 PST
*** Bug 23984 has been marked as a duplicate of this bug. ***
Comment 2 Simon Fraser (smfr) 2009-04-23 22:55:24 PDT
Created attachment 29735 [details]
Patch, changelog, testcases
Comment 3 Simon Fraser (smfr) 2009-04-24 09:11:01 PDT
http://trac.webkit.org/changeset/42823