Bug 231544 - [ iOS 15 ] imported/w3c/web-platform-tests/WebCryptoAPI/derive_bits_keys/pbkdf2.https.any.worker.html is flaky timing out
Summary: [ iOS 15 ] imported/w3c/web-platform-tests/WebCryptoAPI/derive_bits_keys/pbkd...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: WebKit Nightly Build
Hardware: iPhone / iPad Unspecified
: P2 Normal
Assignee: pascoe@apple.com
URL:
Keywords: InRadar
Depends on:
Blocks: 238832 238862
  Show dependency treegraph
 
Reported: 2021-10-11 16:40 PDT by ayumi_kojima
Modified: 2022-04-06 09:42 PDT (History)
10 users (show)

See Also:


Attachments
Diff (380.72 KB, text/plain)
2021-10-11 16:41 PDT, ayumi_kojima
no flags Details
Patch (6.17 MB, patch)
2022-03-29 19:46 PDT, pascoe@apple.com
no flags Details | Formatted Diff | Diff
Patch (6.17 MB, text/plain)
2022-03-31 14:31 PDT, pascoe@apple.com
no flags Details
Patch (6.17 MB, patch)
2022-04-01 16:23 PDT, pascoe@apple.com
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description ayumi_kojima 2021-10-11 16:40:38 PDT
imported/w3c/web-platform-tests/WebCryptoAPI/derive_bits_keys/pbkdf2.https.any.worker.html

Is flaky timing out on iOS 15 Debug.

History: https://results.webkit.org/?suite=layout-tests&test=imported%2Fw3c%2Fweb-platform-tests%2FWebCryptoAPI%2Fderive_bits_keys%2Fpbkdf2.https.any.worker.html

Result page: https://build.webkit.org/results/Apple-iOS-15-Simulator-Debug-WK2-Tests/r283814%20(97)/imported/w3c/web-platform-tests/WebCryptoAPI/derive_bits_keys/pbkdf2.https.any.worker-diff.txt

According to the history, the test was passing on iOS 14 and started being flaky on iOS 15.
Comment 1 ayumi_kojima 2021-10-11 16:41:07 PDT
Created attachment 440858 [details]
Diff
Comment 2 Radar WebKit Bug Importer 2021-10-11 16:42:15 PDT
<rdar://problem/84122086>
Comment 3 ayumi_kojima 2021-10-11 16:46:03 PDT
Updated test expectations https://trac.webkit.org/changeset/283950/webkit
Comment 4 ayumi_kojima 2021-10-15 14:47:10 PDT
It looks like the test is just slow. Updated the expectation to slow to see if this stops the timeouts : https://trac.webkit.org/changeset/284274/webkit
Comment 5 ayumi_kojima 2021-10-21 15:34:40 PDT
The test seems to be still timing out on debug after marked slow.

It usually takes 120 ~ 151 seconds to pass on debug, but shows up as timeout when it takes 154+ seconds.
Comment 6 ayumi_kojima 2021-10-25 11:33:54 PDT
I was not able to reproduce the timeout locally on iOS 15 sim using run-webkit-tests imported/w3c/web-platform-tests/WebCryptoAPI/derive_bits_keys/pbkdf2.https.any.worker.html --iterations 50 --exit-after-n-crashes-or-timeouts 1 --ios-simulator --debug
Comment 7 ayumi_kojima 2021-10-25 11:37:54 PDT
Updated expectation to pass/timeout https://trac.webkit.org/changeset/284800/webkit
Comment 8 pascoe@apple.com 2022-03-29 19:46:01 PDT
Created attachment 456086 [details]
Patch
Comment 9 EWS Watchlist 2022-03-29 19:50:23 PDT
This patch modifies the imported WPT tests. Please ensure that any changes on the tests (not coming from a WPT import) are exported to WPT. Please see https://trac.webkit.org/wiki/WPTExportProcess
Comment 10 pascoe@apple.com 2022-03-31 14:31:29 PDT
Created attachment 456281 [details]
Patch
Comment 11 pascoe@apple.com 2022-04-01 16:23:49 PDT
Created attachment 456417 [details]
Patch
Comment 12 Brent Fulgham 2022-04-04 10:44:28 PDT
Comment on attachment 456417 [details]
Patch

r=me
Comment 13 EWS 2022-04-04 11:32:50 PDT
Committed r292308 (249201@main): <https://commits.webkit.org/249201@main>

All reviewed patches have been landed. Closing bug and clearing flags on attachment 456417 [details].