Bug 231496 - DOMTimeStamp is now EpochTimeStamp
Summary: DOMTimeStamp is now EpochTimeStamp
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: Other
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Chris Dumez
URL:
Keywords: InRadar
: 231498 (view as bug list)
Depends on:
Blocks: 231498
  Show dependency treegraph
 
Reported: 2021-10-10 21:18 PDT by Marcos Caceres
Modified: 2021-10-11 11:06 PDT (History)
16 users (show)

See Also:


Attachments
Patch (33.71 KB, patch)
2021-10-11 08:02 PDT, Chris Dumez
no flags Details | Formatted Diff | Diff
Patch (41.02 KB, patch)
2021-10-11 08:19 PDT, Chris Dumez
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Marcos Caceres 2021-10-10 21:18:01 PDT
DOMTimeStamp was renamed EpochTimeStamp. There is no observable behavioral change - it's just a name change. The HR-Time spec discourages the use of EpochTimeStamp, as it's a legacy feature. 

Relevant WebIDL discussions/issue:
https://github.com/whatwg/webidl/issues/2

Which lead to:
https://github.com/w3c/hr-time/pull/124
Comment 1 Chris Dumez 2021-10-11 08:02:01 PDT
Created attachment 440793 [details]
Patch
Comment 2 Chris Dumez 2021-10-11 08:02:53 PDT
*** Bug 231498 has been marked as a duplicate of this bug. ***
Comment 3 Chris Dumez 2021-10-11 08:19:57 PDT
Created attachment 440796 [details]
Patch
Comment 4 EWS 2021-10-11 11:05:52 PDT
Committed r283912 (242783@main): <https://commits.webkit.org/242783@main>

All reviewed patches have been landed. Closing bug and clearing flags on attachment 440796 [details].
Comment 5 Radar WebKit Bug Importer 2021-10-11 11:06:22 PDT
<rdar://problem/84107219>