Bug 230830 - iOS 15 WKWebview getUserMedia does not return working MediaStream
Summary: iOS 15 WKWebview getUserMedia does not return working MediaStream
Status: RESOLVED DUPLICATE of bug 230479
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebRTC (show other bugs)
Version: Other
Hardware: iPhone / iPad Other
: P2 Major
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-09-27 07:26 PDT by Darius
Modified: 2021-09-27 09:05 PDT (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Darius 2021-09-27 07:26:17 PDT
In a simple app which only calls navigator.mediaDevices.getUserMedia and sets the resulting stream on a video element. The following error shows up whenever getUserMedia is called:

2021-09-27 15:11:28.279138+0100 HelloCordova[1108:514247] Could not create a 'com.apple.tccd' sandbox extension

Could not create a 'com.apple.tccd' sandbox extension
2021-09-27 15:11:28.279245+0100 HelloCordova[1108:514247] [WebRTC] Unable to create com.apple.tccd sandbox extension
The correct info.plist entries are added for camera/mic.

The media device permission dialog shows and is allowed (still shows if permissions were previously granted, and show as granted in the OS private settings).
A MediaStream is a live audio track and a video track is still returned, but setting it on a video element doesn't do anything, neither can the stream be sent over a PeerConnection.
Comment 1 youenn fablet 2021-09-27 07:37:30 PDT
Thanks for the report Darius, this might be bug 230479.
To workaround the issue until bug 230479 ships, you might need to update your custom scheme URL to include a domain name instead of having it empty.
If that is not bug 230479, could you send me a sysdiagnose privately (youenn@apple.com)?
Comment 2 Darius 2021-09-27 07:41:40 PDT
Thanks for the reply Youenn, concur that it is most likely the bug you mentioned as this is in a Cordova app, which uses some cdv:// custom url I suspect.
Comment 3 youenn fablet 2021-09-27 09:05:03 PDT

*** This bug has been marked as a duplicate of bug 230479 ***