Bug 230307 - [GTK][WPE] test animations/steps-transform-rendering-updates.html fails
Summary: [GTK][WPE] test animations/steps-transform-rendering-updates.html fails
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKitGTK (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords:
: 230333 (view as bug list)
Depends on:
Blocks:
 
Reported: 2021-09-15 06:56 PDT by Arcady Goldmints-Orlov
Modified: 2021-09-16 00:34 PDT (History)
13 users (show)

See Also:


Attachments
Patch (1.94 KB, patch)
2021-09-15 07:26 PDT, Carlos Garcia Campos
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Arcady Goldmints-Orlov 2021-09-15 06:56:45 PDT
This test failure was previously hidden but apparently unmasked by the changes in r282383. The failure is as follows.

--- /home/buildbot/worker/gtk-linux-64-release-tests/build/layout-test-results/animations/steps-transform-rendering-updates-expected.txt
+++ /home/buildbot/worker/gtk-linux-64-release-tests/build/layout-test-results/animations/steps-transform-rendering-updates-actual.txt
@@ -1,5 +1,5 @@
 PASS count is 0
-PASS count < 6 is true
+FAIL count < 6 should be true. Was false.
 PASS successfullyParsed is true
 
 TEST COMPLETE
Comment 1 Carlos Garcia Campos 2021-09-15 07:06:55 PDT
I think this only "regressed" in GTK port, in wpe it has always failed.
Comment 2 Carlos Garcia Campos 2021-09-15 07:26:05 PDT
Created attachment 438243 [details]
Patch
Comment 3 Lauro Moura 2021-09-15 19:37:57 PDT
*** Bug 230333 has been marked as a duplicate of this bug. ***
Comment 4 EWS 2021-09-16 00:34:05 PDT
Committed r282490 (241736@main): <https://commits.webkit.org/241736@main>

All reviewed patches have been landed. Closing bug and clearing flags on attachment 438243 [details].