Bug 230214 - REGRESSION(r274929): [CoordinatedGraphics] DrawingAreaCoordinatedGraphics::createDisplayRefreshMonitor is no longer used
Summary: REGRESSION(r274929): [CoordinatedGraphics] DrawingAreaCoordinatedGraphics::cr...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKitGTK (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords: Gtk, Regression
Depends on:
Blocks:
 
Reported: 2021-09-13 05:26 PDT by Carlos Garcia Campos
Modified: 2021-09-15 19:36 PDT (History)
6 users (show)

See Also:


Attachments
Patch (1.65 KB, patch)
2021-09-13 05:31 PDT, Carlos Garcia Campos
aperez: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Carlos Garcia Campos 2021-09-13 05:26:52 PDT
That means we use the right display refresh monitor in the threaded compositor but a different one for rendering update scheduler.
Comment 1 Carlos Garcia Campos 2021-09-13 05:31:05 PDT
Created attachment 438032 [details]
Patch
Comment 2 Carlos Garcia Campos 2021-09-14 02:32:36 PDT
Committed r282383 (241645@main): <https://commits.webkit.org/241645@main>
Comment 3 Arcady Goldmints-Orlov 2021-09-14 08:51:07 PDT
This regressed animations/steps-transform-rendering-updates.html:

--- /home/buildbot/worker/gtk-linux-64-release-tests/build/layout-test-results/animations/steps-transform-rendering-updates-expected.txt
+++ /home/buildbot/worker/gtk-linux-64-release-tests/build/layout-test-results/animations/steps-transform-rendering-updates-actual.txt
@@ -1,5 +1,5 @@
 PASS count is 0
-PASS count < 6 is true
+FAIL count < 6 should be true. Was false.
 PASS successfullyParsed is true
 
 TEST COMPLETE
Comment 4 Arcady Goldmints-Orlov 2021-09-15 06:57:45 PDT
I opened bug 230307 for the test failure which was apparently not so much caused by this change as unmasked by it.
Comment 5 Carlos Alberto Lopez Perez 2021-09-15 19:35:37 PDT
See also bug 230333 .. seems this may have caused flaky timeouts triggering the test run to stop early (it stops at 50 timeouts/crashes)